Zum Inhalt wechseln

Foto
- - - - -

Bluetooth-Dongle streikt immer wieder

USB Bluetooth Dongle El Capitan

  • Bitte melde dich an um zu Antworten
10 Antworten in diesem Thema

#1 OFFLINE   Carson

Carson

    ./kurz davor

  • Members
  • 161 Beiträge
  • OSX:10.11
  • Motherboard: ASRock Z77 Extreme6
  • CPU: Core i7 3,4 MHz
  • Grafikkarte: GeForce GT640
Zeige Hardware

Geschrieben 14 November 2015 - 12:49 Uhr

Hallo zusammen,

 

"Wer bei Apple denkt sich eigentlich so was nettes, wie diese USB-Unterstützung in El Capitan aus :mecker: ?",

so schimpfte in der Shoutbox jetzt Aeneon und ich frage mich, ob da auch mein Problem herrührt.

 

Seit meinem Update auf El Capitan ist eigentlich alles soweit in Ordnung, nur mein Bluetooth-Dongle (F8T065 von Belkin) stellt oft  die Arbeit ein und tut es erst wieder, wenn ich das Teil herausziehe und wieder am selben Port plaziere.

 

Hat jemand eine Idee, wie ich diesem nervigen Umstand Abhilfe schaffe?

 

Dank und Gruß



#2 OFFLINE   wastez

wastez

    ./DSDT86/TimeVortex

  • Administrators
  • 1.391 Beiträge
  • OSX:10.12
  • Motherboard: GA-Z87X-D3H
  • CPU: Intel Core i5 4570
  • Grafikkarte: NVIDIA GT640
Zeige Hardware
2 Hardware Favorit(en)

Geschrieben 14 November 2015 - 20:05 Uhr

Kann natürlich eine USB sache sein.

Hast du USB 3.0 aktiviert und verwendest du El Capitan spezifische fixes für USB generell?

 

Denn seit El Capitan gibt es kaum ein System das nicht modifiziert werden muss.


Motherboard: Gigabyte GA-Z87X-D3H

CPU: Intel Core i5 4570 - 3,6 GHz in Turbo Mode 

RAM: Crucial BallistiX Sport 16 GB DDR3 1600 MHz 

Graphics: Zotac NVIDIA Geforce GT640 2048 MB Zone Edition - personal modded vbios to support UEFI GOP

Sound: Realtek ALC892 - AppleHDA - on the fly patch via Clover

Display: LG 29EA93 - 29" - 21:9 @2560x1080 

 

10.12 macOS Sierra   | Vanilla Kernel | Clover Bootloader - pure UEFI boot - Komponenten werden via dsdt injiziert!!!

 

Hackbook: Toshiba Satellite Pro c850 running on macOS Sierra -- xcpm via kernelpatch enabled --> everything working.... 

 

DataStore:  SelfBuilt NAS - Asrock Q1900-ITX - OpenMediaVault - read: 117 mb/s write: 110 mb/s


#3 OFFLINE   Carson

Carson

    ./kurz davor

  • Members
  • 161 Beiträge
  • OSX:10.11
  • Motherboard: ASRock Z77 Extreme6
  • CPU: Core i7 3,4 MHz
  • Grafikkarte: GeForce GT640
Zeige Hardware

Geschrieben 14 November 2015 - 21:44 Uhr

Ich hab seit Yosemite keine zusätzlichen Fixes, also auch keine in puncto USB angewendet.

War mir nicht klar, dass ich da "aufrüsten" muss.

Heißt das, ich sollte den Haken vor dem USB-Fix im Clover Configurator standardmäßig und hardwareunabhängig setzen?

Ich frag auch deswegen, weil ich das Abschmieren des USB-Dongles nicht provozieren kann. Austesten eines USB-Fixes ist deshalb bei meinem Problem schwierig.

#4 OFFLINE   wastez

wastez

    ./DSDT86/TimeVortex

  • Administrators
  • 1.391 Beiträge
  • OSX:10.12
  • Motherboard: GA-Z87X-D3H
  • CPU: Intel Core i5 4570
  • Grafikkarte: NVIDIA GT640
Zeige Hardware
2 Hardware Favorit(en)

Geschrieben 15 November 2015 - 05:03 Uhr

Ich hab seit Yosemite keine zusätzlichen Fixes, also auch keine in puncto USB angewendet.

War mir nicht klar, dass ich da "aufrüsten" muss.

Heißt das, ich sollte den Haken vor dem USB-Fix im Clover Configurator standardmäßig und hardwareunabhängig setzen?

Ich frag auch deswegen, weil ich das Abschmieren des USB-Dongles nicht provozieren kann. Austesten eines USB-Fixes ist deshalb bei meinem Problem schwierig.

Ich versteh jetzt nicht ganz: Verwendest du nun Yosemite oder schon El Capitan? Weil du das Wort seit verwendet hast bin ich mir da nicht ganz sicher.

Bei Yosemite gibt es nichts neues, erst ab El Capitan.

Kommt natürlich auch drauf an on du für USB 3.0 den GenericXHCI Treiber verwendest? Denn seit El Capitan funkt das auch nicht mehr.

Du siehst etwas mehr infos wären gut.


Motherboard: Gigabyte GA-Z87X-D3H

CPU: Intel Core i5 4570 - 3,6 GHz in Turbo Mode 

RAM: Crucial BallistiX Sport 16 GB DDR3 1600 MHz 

Graphics: Zotac NVIDIA Geforce GT640 2048 MB Zone Edition - personal modded vbios to support UEFI GOP

Sound: Realtek ALC892 - AppleHDA - on the fly patch via Clover

Display: LG 29EA93 - 29" - 21:9 @2560x1080 

 

10.12 macOS Sierra   | Vanilla Kernel | Clover Bootloader - pure UEFI boot - Komponenten werden via dsdt injiziert!!!

 

Hackbook: Toshiba Satellite Pro c850 running on macOS Sierra -- xcpm via kernelpatch enabled --> everything working.... 

 

DataStore:  SelfBuilt NAS - Asrock Q1900-ITX - OpenMediaVault - read: 117 mb/s write: 110 mb/s


#5 OFFLINE   Carson

Carson

    ./kurz davor

  • Members
  • 161 Beiträge
  • OSX:10.11
  • Motherboard: ASRock Z77 Extreme6
  • CPU: Core i7 3,4 MHz
  • Grafikkarte: GeForce GT640
Zeige Hardware

Geschrieben 15 November 2015 - 15:02 Uhr

Also, ich benutze El Capitan und habe bislang keinen Treiber für USB 3.0 installiert.

Demnach scheint mein Dongle also im USB-2.0-Betrieb zu haken.

Kann ich quasi auf Verdacht einen USB-Fix unter Clover verwenden ohnen mir anderweitig Scherereien einzuhandeln?

Denn außer dem Dongle ist alles andere bislang unauffällig.

#6 OFFLINE   wastez

wastez

    ./DSDT86/TimeVortex

  • Administrators
  • 1.391 Beiträge
  • OSX:10.12
  • Motherboard: GA-Z87X-D3H
  • CPU: Intel Core i5 4570
  • Grafikkarte: NVIDIA GT640
Zeige Hardware
2 Hardware Favorit(en)

Geschrieben 15 November 2015 - 20:46 Uhr

Das ist es eben, du brauchst keinen XHCI Treiber installieren, er versucht ihn zu verwenden und wenn dass nicht passt dann funktioniert er einfach nicht wie er soll.

 

Auch USB 2.0 muss neu angepasst werden falls er nicht funktioniert wie er sollte.

 

Edit:

Ich würde dir vorschlagen dass du diese kext verwendest weil da schon alles vorkonfiguriert ist: https://bitbucket.or...ct-all/overview

 

Du musst lediglich schauen dass EHC1 in EH1, EHC2 in EH2 und XHC1 in XHC umbennant ist. (bei jedem Mainboard weichen die Namen etwas ab)

 

Ansonsten musst du nur die kext installieren.


Motherboard: Gigabyte GA-Z87X-D3H

CPU: Intel Core i5 4570 - 3,6 GHz in Turbo Mode 

RAM: Crucial BallistiX Sport 16 GB DDR3 1600 MHz 

Graphics: Zotac NVIDIA Geforce GT640 2048 MB Zone Edition - personal modded vbios to support UEFI GOP

Sound: Realtek ALC892 - AppleHDA - on the fly patch via Clover

Display: LG 29EA93 - 29" - 21:9 @2560x1080 

 

10.12 macOS Sierra   | Vanilla Kernel | Clover Bootloader - pure UEFI boot - Komponenten werden via dsdt injiziert!!!

 

Hackbook: Toshiba Satellite Pro c850 running on macOS Sierra -- xcpm via kernelpatch enabled --> everything working.... 

 

DataStore:  SelfBuilt NAS - Asrock Q1900-ITX - OpenMediaVault - read: 117 mb/s write: 110 mb/s


#7 OFFLINE   Carson

Carson

    ./kurz davor

  • Members
  • 161 Beiträge
  • OSX:10.11
  • Motherboard: ASRock Z77 Extreme6
  • CPU: Core i7 3,4 MHz
  • Grafikkarte: GeForce GT640
Zeige Hardware

Geschrieben 15 November 2015 - 23:08 Uhr

Gaaaaanz herzlichen Dank, wird morgen ausprobiert!



#8 OFFLINE   Carson

Carson

    ./kurz davor

  • Members
  • 161 Beiträge
  • OSX:10.11
  • Motherboard: ASRock Z77 Extreme6
  • CPU: Core i7 3,4 MHz
  • Grafikkarte: GeForce GT640
Zeige Hardware

Geschrieben 19 November 2015 - 22:11 Uhr

[Entschuldigt den Doppel-Post, aber sonst kriegt keiner was mit.]

Bin aufgrund der Anforderungen bürgerlichen Broterwerbs erst jetzt dazu gekommen, die Kext auszuprobieren. Mein "Mac" stellt nach Ablage im 10.11-Ordner von Clover das Booten ein.

Allerdings ist mir dann noch eingefallen, dass ich ja vermutlich sehr wohl USB gepatcht haben dürfte, nämlich über den Rundum-Sorglos-DSDT-Patch von PJALM für mein MoBo.

Zudem ist mir als Immer-Noch-Anfänger nicht klar, wo ich die oben erwähnten Änderungen (EHC1 ändern in EH1 usw. ...) vornehmen muss. In der info.plist der Kext habe ich solche Einträge nicht gefunden.

Wenn ich da nochmal ein wenig Erleuchtung bekommen könnte, wüsste ich das sehr zu schätzen.

Dank und Gruß

Bearbeitet von Carson, 19 November 2015 - 22:44 Uhr.


#9 OFFLINE   lord_webi

lord_webi

    MOS-6502

  • Administrators
  • 9.662 Beiträge
  • LocationHIT ANY KEY TO BEGIN
  • OSX:10.10
  • Motherboard: Asus X99-A
  • CPU: i7-5930K@3,5GHz
  • Grafikkarte: GTX 970 4GB
Zeige Hardware
1 Hardware Favorit(en)

Geschrieben 19 November 2015 - 22:58 Uhr

in der DSDT ... 10.11 Ordner :engel:


My Silent Hacki's:

 

macOS Sierra 10.12.2

GA-P55A-UD3 - i5 760@2.93GHz - 16GB DDR3 RAM - Zotac Zone GTX 750 TI 2GB passiv - 480GB SSD - 2x 250GB HDD - 1x 512GB HDD

Apple KeyBoard - Creative SoundBlaster Omni Surround 5.1 USB - Logitech Z-5300 5.1 THX

 

Yosemite 10.10.5

Asus X99-A - i7-5930K @ 3.5GHz - 16 GB DDR4-2133 Kingston HyperX Fury - Asus STRIX - GTX 970 4 GB silent

4x Samsung SSD - 16x LG BD Brenner

 

Bootloader: :cloverli:


#10 OFFLINE   wastez

wastez

    ./DSDT86/TimeVortex

  • Administrators
  • 1.391 Beiträge
  • OSX:10.12
  • Motherboard: GA-Z87X-D3H
  • CPU: Intel Core i5 4570
  • Grafikkarte: NVIDIA GT640
Zeige Hardware
2 Hardware Favorit(en)

Geschrieben 20 November 2015 - 01:07 Uhr

[Entschuldigt den Doppel-Post, aber sonst kriegt keiner was mit.]

Bin aufgrund der Anforderungen bürgerlichen Broterwerbs erst jetzt dazu gekommen, die Kext auszuprobieren. Mein "Mac" stellt nach Ablage im 10.11-Ordner von Clover das Booten ein.

Allerdings ist mir dann noch eingefallen, dass ich ja vermutlich sehr wohl USB gepatcht haben dürfte, nämlich über den Rundum-Sorglos-DSDT-Patch von PJALM für mein MoBo.

Zudem ist mir als Immer-Noch-Anfänger nicht klar, wo ich die oben erwähnten Änderungen (EHC1 ändern in EH1 usw. ...) vornehmen muss. In der info.plist der Kext habe ich solche Einträge nicht gefunden.

Wenn ich da nochmal ein wenig Erleuchtung bekommen könnte, wüsste ich das sehr zu schätzen.

Dank und Gruß

Die DSDT patches reichen seit 10.11 nicht mehr, das hat sich alles geändert, der ganze USB Stack wurde neu aufgebaut.

Dass es Probleme geben kann wenn du das nicht zuerst in der dsdt änderst ist auch klar.

Ich rede davon dass in der dsdt EHC1 zu EH1 usw. geändert werden soll.

Diese kext ist der einfachste Weg weil so gut wie nichts mehr gemacht werden muss, ich wollte dir nicht antun dass du die Werte selbst aus dem dsdt auslesen musst.


  • lord_webi gefällt das

Motherboard: Gigabyte GA-Z87X-D3H

CPU: Intel Core i5 4570 - 3,6 GHz in Turbo Mode 

RAM: Crucial BallistiX Sport 16 GB DDR3 1600 MHz 

Graphics: Zotac NVIDIA Geforce GT640 2048 MB Zone Edition - personal modded vbios to support UEFI GOP

Sound: Realtek ALC892 - AppleHDA - on the fly patch via Clover

Display: LG 29EA93 - 29" - 21:9 @2560x1080 

 

10.12 macOS Sierra   | Vanilla Kernel | Clover Bootloader - pure UEFI boot - Komponenten werden via dsdt injiziert!!!

 

Hackbook: Toshiba Satellite Pro c850 running on macOS Sierra -- xcpm via kernelpatch enabled --> everything working.... 

 

DataStore:  SelfBuilt NAS - Asrock Q1900-ITX - OpenMediaVault - read: 117 mb/s write: 110 mb/s


#11 OFFLINE   Carson

Carson

    ./kurz davor

  • Members
  • 161 Beiträge
  • OSX:10.11
  • Motherboard: ASRock Z77 Extreme6
  • CPU: Core i7 3,4 MHz
  • Grafikkarte: GeForce GT640
Zeige Hardware

Geschrieben 20 November 2015 - 06:13 Uhr

Okay, wird nach Feierabend probiert, vielen Dank!







Auch mit einem oder mehreren dieser Stichwörter versehen: USB, Bluetooth, Dongle, El Capitan

Aktive Besucher in diesem Forum: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0