Zum Inhalt wechseln

Foto
- - - - -

GA Z97X gaming 3 - USB 3 / Sound not working


  • Bitte melde dich an um zu Antworten
63 Antworten in diesem Thema

#61 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.606 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 21 Februar 2017 - 19:56 Uhr

Zur SSDT-1 für USB3 kann ich Dir nix sagen, aber für USB3 gibt´s ja einige Lösungen.

 

Für die anderen Probleme, könntest Du mal beide DSDT-Versionen posten um die beiden zu vergleichen. Vielleicht kann man da eine gut gehende draus machen für Dich.

Benenne die so, dass man erkennt welche nun welche ist. Spätestens am WE schaue ich mir das gern mal an.

 

Die ID 1 sollte schon besser in der DSDT gesetzt werden, wenn man schon eine verwendet, jedoch dafür müsste ich beide einsehen und vergleichen.


Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 MSI GT710 2GB passiv  42" LG  250GB SSD: 10.15 DP3 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  500GB SSD: 10.10.5 / 10.14.6 DP3 / 10.15 DP3 (APFS)
Medion P9614: C2D T9600  2,80GHz  4GB DDR3  GT330M 512MB 23,6" intern  250GB SSD: 10.13.6 / 10.14.6 DP3 / 10.15 DP3 (APFS)

THINKPAD T61p: C2D T9300  2,50GHz  4GB DDR2  nvidia Quadro FX 570M 256MB  15,4" intern  120GB SSD: 10.14.6 DP2 / 10.15 DP3 (APFS)

root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  MSI GT710 2GB passiv/ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: 10.14.6 DP3 / 10.15 DP3 (APFS)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.5 (HFS+)
iPhone6 64GB: iOS 12.3.1  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.3.1


#62 OFFLINE   imox

imox

    GCM 1

  • Members
  • 373 Beiträge

Geschrieben 22 Februar 2017 - 10:47 Uhr

Das Problem mit dem USB3 ist irgendwie, dass wenn ich eine DSDT verwende das nicht richtig funktioniert. Ohne DSDT funktioniert USB3 ohne kexte etc. einwandfrei. Das Problem ist auch mit beiden DSDT's gleich. Deswegen weiß ich da grad nicht wirklich weiter. Ich habe dir jetzt hier mal beide DSDT's und die SSDT und SSDT-1 angehangen. Die SSDT müsste noch falsch sein, da die für den i7 ist ich hab ja einen i5. 

Angehängte Dateien

  • Angehängte Datei  DSDT.zip   46,27K   3 Mal heruntergeladen

GA-Z97X-Gaming 3

Intel® Core™ i5-4690K

16GB RAM

Geforce GTX 660 Ti

Samsung SSD 850 Evo 256 GB

10.14.2

 

MacBook Pro Retina 13" (Mid 2014)

3 GHz i7

16 GB RAM

512 GB SSD

10.14.2


#63 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.606 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 22 Februar 2017 - 17:57 Uhr

Bei den SSDT´s kann ich Dir nicht viel helfen. Die für die CPU kannst Du aber mit diesem Piker´s Script für Deinen i5 erstellen, denn die vom i7 wird nicht passen.

Die für´s USB, keine Ahnung ob die für Dein Board gedacht ist. Du hast allerdings in der config.plist noch die 15 Portanhebung drin, vielleicht normal sich dies gegenseitig. Aber wie gesagt, da kann ich nicht viel zu sagen.

Zitat: Ohne DSDT funktioniert USB3...

Bitte genauer!!! Ohne DSDT aber mit dieser SSDT1 oder nur mit der config.plist und der Portanhebung?

Die DSDT´s vergleiche ich mal am WE zwecks der anderen Probleme.


Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 MSI GT710 2GB passiv  42" LG  250GB SSD: 10.15 DP3 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  500GB SSD: 10.10.5 / 10.14.6 DP3 / 10.15 DP3 (APFS)
Medion P9614: C2D T9600  2,80GHz  4GB DDR3  GT330M 512MB 23,6" intern  250GB SSD: 10.13.6 / 10.14.6 DP3 / 10.15 DP3 (APFS)

THINKPAD T61p: C2D T9300  2,50GHz  4GB DDR2  nvidia Quadro FX 570M 256MB  15,4" intern  120GB SSD: 10.14.6 DP2 / 10.15 DP3 (APFS)

root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  MSI GT710 2GB passiv/ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: 10.14.6 DP3 / 10.15 DP3 (APFS)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.5 (HFS+)
iPhone6 64GB: iOS 12.3.1  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.3.1


#64 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.606 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 24 Februar 2017 - 19:24 Uhr

Mein lieber imox, dat ist ja Hardcore mit Dir.  :hihihi:

 

Die DSDT_Gaming_3.aml hast Du schon wieder irgendwie verbogen, lässt sich gar nicht mehr öffnen, somit habe ich zum Vergleich mal das Original von al6042 herangezogen.

Da Du ja wohl mit der von Dir irgendwo geladenen DSDT_UD3H mehr Erfolg zwecks Grafik und Sleep hast, habe ich mal auch hier angesetzt.

So sehr unterschiedlich sind sie in vielen Sachen nicht, aber egal.

In der DSDT_UD3H habe ich noch die IRQ´s gefixt, was dort noch fehlte und habe dort den HDEF-Bereich für´s Audio LayoutID 1 eingefügt. Somit sollte der Inject mit der DSDT statt im Clover funktionieren.

Zwecks USB haben beide DSDT´s so viele Einträge, schwer da durchzusehen. Vielleicht versuchst Du es mit dem USB mal nur mit der DSDT, ohne USB-Krams im Clover.

 

Hier das Ergebnis für Deine Test´s: Angehängte Datei  DSDT.aml.zip   22,79K   5 Mal heruntergeladen

 

Ferner verwendest Du irgendeine FakeSMC, die nicht das Original ist und auch nicht die neuste Version. Keine Ahnung wo Du Deinen Kram her bekommst.

Lösche mal alle markierten Kexte auf dem Bild aus Deinem Kext-Ordner 10.12:

 

Angehängte Datei  aus_10_12_löschen_und_ersetzen.png   64,09K   0 Mal heruntergeladen

 

... und ersetze diese durch: Angehängte Datei  FakeSMC.kext.zip   161,38K   4 Mal heruntergeladen

 

... in dieser sind die vier Sensoren bereits als PlugIn eingebaut, so wie es sein soll.

 

Des Weiteren verwendest Du in Deinem EFI/Clover/drivers64UEFI/ - Ordner sowohl OsxAptioFixDrv-64.efi als auch OsxAptioFix2Drv-64.efi:

 

Angehängte Datei  einen_nur.png   84,61K   0 Mal heruntergeladen

 

... bitte nur einen verwenden, nicht beide! Im Normal immer erst den OsxAptioFixDrv-64.efi versuchen, erst wenn es negative Meldungen zwecks Speicher etc. gibt, dann den anderen versuchen.


  • qsecofr gefällt das

Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 MSI GT710 2GB passiv  42" LG  250GB SSD: 10.15 DP3 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  500GB SSD: 10.10.5 / 10.14.6 DP3 / 10.15 DP3 (APFS)
Medion P9614: C2D T9600  2,80GHz  4GB DDR3  GT330M 512MB 23,6" intern  250GB SSD: 10.13.6 / 10.14.6 DP3 / 10.15 DP3 (APFS)

THINKPAD T61p: C2D T9300  2,50GHz  4GB DDR2  nvidia Quadro FX 570M 256MB  15,4" intern  120GB SSD: 10.14.6 DP2 / 10.15 DP3 (APFS)

root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  MSI GT710 2GB passiv/ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: 10.14.6 DP3 / 10.15 DP3 (APFS)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.5 (HFS+)
iPhone6 64GB: iOS 12.3.1  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.3.1





Aktive Besucher in diesem Forum: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0