Zum Inhalt wechseln

Foto
- - - - -

nochmal HD4000 Auflösungsproblem


  • Bitte melde dich an um zu Antworten
28 Antworten in diesem Thema

#1 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 1.824 Beiträge
  • OSX:10.12
  • Motherboard: Intel DH67VR BIOS 1.60
  • CPU: CoreI3 3225
  • Grafikkarte: Intel HD4000 onboard
Zeige Hardware

Geschrieben 11 November 2017 - 20:05 Uhr

Hallo Kinders,

da im Augenblick hier nicht so viel los ist haue ich nochmal mein Auflösungsproblem rein.

Die HD4000 läuft ja mit 1080p in 60 und 50 Hz super und das ganze System ist sehr stabil und Dank DSDT updatesicher.

 

ABER: 

Ich kann NUR die 1080p nehmen. :sholva:

ALLE anderen Auflösungen sind unlesbar. 5mal überlappt, zu lang für den Bildschirm usw.

 

Ich gehe über HDMI auf ein 24" TV Gerät.

 

Steve hat mir das Ding hier mal geraten:

https://github.com/F...-clock-patch-V2

 

Ich trau mich aber nicht ran, weil ich überhaupt nicht verstehe was das Ding macht.

Ist das überhaupt für die Intel HDs gedacht? Ich lese immer nur was von Nvidia Karten?

 

Oder hat jemand sonst einen Link oder Fix dafür ?

 

Ich beschäftige mich gerade für ein paar Retrogames mit Wine2 und dabei fällt mir mein Auflösungsproblem

wieder auf die Füße, weil hier wieder mehrere Auflösungen gebraucht werden....

 

Mein VM Ware Fusion ist mir in der Grafik zu langsam.... selbst für Myst4...  

 

Ich freue mich über jegliche Anregung, auch zum Thema Wine. Geht das auch grafisch als Fenster ?


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Hack Mini:
Mainboard: 
Intel DH67VR / BIOS 160, Core I3 3225, 4GB RAM, Intel HD4000 onboard 256MB VRAM, 500GB Hitachi HDD

OS X 10.13.4

Hack Billig :
Mainboard: Gigabyte GA-G31M-S2L BIOS F9, Core2Duo 6400, Gigabyte Radeon 5450, 4GB DDR2 RAM, 500GB HDD WDi 2,5"
OS X 10.10.5


#2 ONLINE   blade5502

blade5502

    /dev/MacGenius86

  • Administrators
  • 1.365 Beiträge
  • OSX:10.13
  • Motherboard: MSI Pro-E X58
  • CPU: Intel Xeon X5650
  • Grafikkarte: GTX 1070
Zeige Hardware
2 Hardware Favorit(en)

Geschrieben 11 November 2017 - 20:43 Uhr

Hallo konfu,

 

der Patch ist für Auflösungen > FullHD - bei dir gehts aber wohl eher um kleinere Auflösungen wenn ich das richtig rauslese!

 

Das überlappen kommt eher nicht vom Mac, sondern vom TV.

 

TVs haben allgemein die Angewohnheit Bildsignale künstlich zu "verschlimmbessern". Das mag ut für jegliche art von Setupbox zu sein, allerdings nicht für Computerinput. Sieh dir mal Bildeinstellungen vom TV durch!

 

Zu Wine - verwendest du ein nacktes Wine oder in Verbindung mit einer Konfigurationsgui (ich verwende beispielsweise PlayOnMac bzw. alternativ Wineskin Winery)? Grundsätzlich kannst du unter winecfg > Emulate a virtual Desktop anhaken und die gewünschte Auflösung einstellen


  • MacPeet gefällt das
root_sig.png

 

 


#3 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 1.824 Beiträge
  • OSX:10.12
  • Motherboard: Intel DH67VR BIOS 1.60
  • CPU: CoreI3 3225
  • Grafikkarte: Intel HD4000 onboard
Zeige Hardware

Geschrieben 12 November 2017 - 19:12 Uhr

Ok, Danke für das Feedback,

es geht um die niedrigen Auflösungen, richtig.

Das Problem ist, dass das 24" TV Gerät auch eine DVI/HDMI Schnittstelle hat und die verdaut mit Linux

problemlos alle Auflösungen. Auch mit Windoof geht das . Nur halt mit dem OS X nicht. Deshalb meine "Ratsuche"...

 

Ich habe nur Wine2.0 geladen und auch mit Winecfg versucht die Auflösung für die Anwendung vorzugeben.

Leider Geht das bei Myst 4 nur bis 1024x768.  Im Game gibt es auch eine  .ini Datei, wo man die Auflösung 

eintragen kann, sie muss aber plausibel sein, sonst nimmt er das maximal mögliche. Die Änderung sieht man daran, dass

das zerstörte Bild anders kaputt ist.

 

Ich habe auch einen 24" Samsung Monitor mit HDMI>DVI Adapter versucht und da sieht alles exakt genau so aus wie auf dem TV...

 

Ich forsche weiter und bin weiterhin für Ideen offen.


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Hack Mini:
Mainboard: 
Intel DH67VR / BIOS 160, Core I3 3225, 4GB RAM, Intel HD4000 onboard 256MB VRAM, 500GB Hitachi HDD

OS X 10.13.4

Hack Billig :
Mainboard: Gigabyte GA-G31M-S2L BIOS F9, Core2Duo 6400, Gigabyte Radeon 5450, 4GB DDR2 RAM, 500GB HDD WDi 2,5"
OS X 10.10.5


#4 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 1.824 Beiträge
  • OSX:10.12
  • Motherboard: Intel DH67VR BIOS 1.60
  • CPU: CoreI3 3225
  • Grafikkarte: Intel HD4000 onboard
Zeige Hardware

Geschrieben 14 November 2017 - 19:50 Uhr

Ok, Erkenntnis gewonnen durch Netzfund:

 

Man trage die "ig-Platform-id  0x01660003" im Clover mit Haken bei "Inject EIDID" und "Inject Intel"  ein !      :kamerad:

 

Das tat ich, obwohl meine HD4000 ja in der DSDT geregelt ist trotzdem.   :wiejetzt:

 

Das Resultat: In der Systemsteuerung habe ich nun 2 Monitore, beide identisch klar ist ja nur einer, 

 

ABER !!   Alle Auflösungen laufen! Egal, ob ich die beim ersten oder zweiten  im System verstelle.

 

Leider ist erwartungsgemäß der HDMI Ton weg. Ist auch nicht reaktivierbar. Klar bei 2 Monitoren die nur einer sind...

Also die gesicherte Config zurückgespielt und alles ist beim alten. Ton da, Auflösungen weg.

Die empfohlene ig-Platform-id ist wohl besser für mich geeignet scheint mir.

 

Frage nun an den MacPeet:  Du hast mal meine letzte DSDT angeschaut, hast Du die noch ?

Kann dort diese Platform ID drinnen sein ? Ich finde die da nicht?   :sholva:

 

Wie kann ich das nun lösen?  Ich habe diesen Patch drinnen "Ivy Bridge HD4000 on 6er Board" der im MacIASL verfügbar ist.


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Hack Mini:
Mainboard: 
Intel DH67VR / BIOS 160, Core I3 3225, 4GB RAM, Intel HD4000 onboard 256MB VRAM, 500GB Hitachi HDD

OS X 10.13.4

Hack Billig :
Mainboard: Gigabyte GA-G31M-S2L BIOS F9, Core2Duo 6400, Gigabyte Radeon 5450, 4GB DDR2 RAM, 500GB HDD WDi 2,5"
OS X 10.10.5


#5 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.266 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 15 November 2017 - 14:50 Uhr

Nee, hab ich hier nicht mehr liegen. Schicke es mir ggf. mal via PM.

DSDT und möglichst auch ein ioreg von beiden Möglichkeiten.

Ist die id denn auch für einen Desktop? Hatte folgende Info gefunden: 0x01660003 - Ivy Bridge Mobile GT2


Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 GT710 2GB passiv  42" LG  250GB SSD: 10.14.3 DP4 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  250GB SSD: 10.10.5 / 10.14.3 DP4 (APFS)
Medion P9614: C2D T9600  2,80GHz(2,93GHz)  4GB DDR3  GT330M 512MB 23,6" intern  128GB SSD: 10.13.6 / 10.14.3 DP4 (APFS)
root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: all old versions / 10.13.6 / 10.14.2 (HFS+)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.2 (HFS+)
iPhone6 64GB: iOS 10.3.3  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.1.1


#6 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 1.824 Beiträge
  • OSX:10.12
  • Motherboard: Intel DH67VR BIOS 1.60
  • CPU: CoreI3 3225
  • Grafikkarte: Intel HD4000 onboard
Zeige Hardware

Geschrieben 15 November 2017 - 19:08 Uhr

Ja genau, für Mobile als Macbook 9.2 ?   geeignet. Deshalb habe ich die auch nie versucht.  :null:

Um so verwunderter war ich, als ich bei Youtube ein Video fand, wo jemand diese für alle Varianten empfahl. :wiejetzt:

 

Für einen Test bin ich ja immer zu haben...


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Hack Mini:
Mainboard: 
Intel DH67VR / BIOS 160, Core I3 3225, 4GB RAM, Intel HD4000 onboard 256MB VRAM, 500GB Hitachi HDD

OS X 10.13.4

Hack Billig :
Mainboard: Gigabyte GA-G31M-S2L BIOS F9, Core2Duo 6400, Gigabyte Radeon 5450, 4GB DDR2 RAM, 500GB HDD WDi 2,5"
OS X 10.10.5


#7 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.266 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 16 November 2017 - 12:03 Uhr

Du verwendest ja auch SMBIOS MacMini6,2 und es ist auch ein Desktoprechner und kein Lappi, oder?

 

Also, im ioreg welches mit FullHD läuft, geht die Grafik auf den acpi-path: IOACPIPlane:/_SB/PCI0@0/IGPU@20000 und auf 0x0166000a

Weil in der DSDT kein HDAU konfiguriert ist, jedoch aber Dein Haken bei UseHDMIAudio, greift dieser Cloverpatch auf dem acpi-path

 

Mit der 0x01660003 scheint es wohl zu gehen, jedoch im ioreg gibt´s kein acpi-path mehr. Dadurch greift der HDMIAudio-Patch wohl auch nicht.

 

Ferner ist Deine DSDT so gut wie gar nicht gepatcht. Du hast lediglich HDEF mit LayoutID 3 drin und den MEI-Patch.

Einen iGPU-Patch HD4000 gibt´s nicht, auch keine DTGP-Methode, auch keine generellen Patches.

 

Ich weiß ja nicht welche Patches dafür in der CloverConfig noch geregelt sind.

Wenn Du nach dem Booten MaciASL startest, dann wird eigentlich die DSDT eingelesen mit allen Patches, die von Clover noch eingefügt wurden.

 

Ist dies ein Intel 6 Chipsatz? Ein Ivy?

Mach doch mal ein Bild vom DPCIManager vom Tab "PCIList"!


Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 GT710 2GB passiv  42" LG  250GB SSD: 10.14.3 DP4 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  250GB SSD: 10.10.5 / 10.14.3 DP4 (APFS)
Medion P9614: C2D T9600  2,80GHz(2,93GHz)  4GB DDR3  GT330M 512MB 23,6" intern  128GB SSD: 10.13.6 / 10.14.3 DP4 (APFS)
root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: all old versions / 10.13.6 / 10.14.2 (HFS+)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.2 (HFS+)
iPhone6 64GB: iOS 10.3.3  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.1.1


#8 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 1.824 Beiträge
  • OSX:10.12
  • Motherboard: Intel DH67VR BIOS 1.60
  • CPU: CoreI3 3225
  • Grafikkarte: Intel HD4000 onboard
Zeige Hardware

Geschrieben 16 November 2017 - 18:46 Uhr

Alles korrekt erkannt !   

Mac Mini 6.2 SMBIOS und DSDT nur mit den 2 Patches.

Im Clover sind nur der Haken bei UseIntelHDMI und ApplePM gesetzt. Alle anderen sind raus.

 

Auch bei Graphics ist kein einziger. Für den ALC sind 2 Einträge vom Piker Alpha Script drinnen, wenn die raus sind geht der HDMI aber auch, deshalb sind die unwichtig.

 

Chipset ist das H67 und CPU ist ein Ivy Bridge I3 3225.  Deshalb der MEI Patch, vorher war das Problem doch, das er die HD4000 nur jedes 5. Mal erkannte...

 

Wie gesagt, mit der zusätzlichen 0x01660003 ID ist mein Monitor 2mal in den Systemeinstellungen, als wenn ich 2 physikalische Geräte dran hätte...

 

Bilder vom DPCI Manager im Anhang. Der HDMI Sound wird als HD3000 angezeigt.

Angehängte Dateien


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Hack Mini:
Mainboard: 
Intel DH67VR / BIOS 160, Core I3 3225, 4GB RAM, Intel HD4000 onboard 256MB VRAM, 500GB Hitachi HDD

OS X 10.13.4

Hack Billig :
Mainboard: Gigabyte GA-G31M-S2L BIOS F9, Core2Duo 6400, Gigabyte Radeon 5450, 4GB DDR2 RAM, 500GB HDD WDi 2,5"
OS X 10.10.5


#9 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.266 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 16 November 2017 - 19:36 Uhr

Ich werd bei Dir immer nicht ganz schlau. DPCIManager zeigt eine HD3000 beim AudioDevice als SandyBridge.

Ist dat nun tatsächlich eine HD4000 Ivy ???

 

So, ich hab mal einiges gepatcht. Versuche nacheinander! Bitte keine ig-platform-id im Clover eintragen, ich habe dies jeweils als iGPU-Patch in der DSDT gemacht mit HDAU-Eintrag für das HDMI-Audio.

 

Angehängte Datei  DSDT.aml_mit 0x0166000a_und HDAU.zip   11,87K   1 Mal heruntergeladen

 

Angehängte Datei  DSDT.aml_mit 0x01660003_und HDAU.zip   11,89K   1 Mal heruntergeladen

 

Die DSDT´s jeweils im EFI/Clover/ACPI/patched/ tauschen und versuchen!


Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 GT710 2GB passiv  42" LG  250GB SSD: 10.14.3 DP4 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  250GB SSD: 10.10.5 / 10.14.3 DP4 (APFS)
Medion P9614: C2D T9600  2,80GHz(2,93GHz)  4GB DDR3  GT330M 512MB 23,6" intern  128GB SSD: 10.13.6 / 10.14.3 DP4 (APFS)
root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: all old versions / 10.13.6 / 10.14.2 (HFS+)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.2 (HFS+)
iPhone6 64GB: iOS 10.3.3  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.1.1


#10 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 1.824 Beiträge
  • OSX:10.12
  • Motherboard: Intel DH67VR BIOS 1.60
  • CPU: CoreI3 3225
  • Grafikkarte: Intel HD4000 onboard
Zeige Hardware

Geschrieben 16 November 2017 - 19:39 Uhr

Das ist ein I3 3225 Ivy Bridge also HD4000. Warum der Ton als HD3000 ausgegeben wird , keine Ahnung,  sehe ich heute das erste Mal. Weil ich auch nie mit dem DPCI Manager reingeschaut habe, 

 

Ok, die DSDTs laufen beide, mit der 0166000a bleibt alles wie gehabt, nur 1080p und HDMI Ton

 mit der 01660003 jetzt nur ein Monitor , wie es sein soll und 720p läuft auch. Aber kein Ton.

 

Ich habe testweise die SMBIOS mal auf Macbook Pro 9.2 gesetzt, das ist ihm egal.

Ist alles identisch mit SMBIOS MacMini.


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Hack Mini:
Mainboard: 
Intel DH67VR / BIOS 160, Core I3 3225, 4GB RAM, Intel HD4000 onboard 256MB VRAM, 500GB Hitachi HDD

OS X 10.13.4

Hack Billig :
Mainboard: Gigabyte GA-G31M-S2L BIOS F9, Core2Duo 6400, Gigabyte Radeon 5450, 4GB DDR2 RAM, 500GB HDD WDi 2,5"
OS X 10.10.5


#11 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.266 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 16 November 2017 - 20:38 Uhr

Am SMBIOS brauchst Du nicht rumspielen, MacMini ist ok.

Na immerhin nur noch ein Monitor bei dem iGPU-HD400-Patch mit ig-01660003-id.

 

So ganz viel Ideen hab ich auch nicht mehr, aber schicke mir mal nochmals von beiden Varianten ein ioreg via PM, bitte!


Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 GT710 2GB passiv  42" LG  250GB SSD: 10.14.3 DP4 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  250GB SSD: 10.10.5 / 10.14.3 DP4 (APFS)
Medion P9614: C2D T9600  2,80GHz(2,93GHz)  4GB DDR3  GT330M 512MB 23,6" intern  128GB SSD: 10.13.6 / 10.14.3 DP4 (APFS)
root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: all old versions / 10.13.6 / 10.14.2 (HFS+)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.2 (HFS+)
iPhone6 64GB: iOS 10.3.3  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.1.1


#12 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.266 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 17 November 2017 - 11:25 Uhr

Ich hatte HDAU falsch eingefügt und nun geändert. Mal sehen ob es was bringt.

Ferner habe ich MEI noch in IMEI umbenannt. Soll so wohl richtig sein für die iGPU´s.

 

Mal was anderes. Hast Du im Bios auch die Werte erhöht? Dort sollte auf 64MB bzw. auf 96MB erhöht werden.

 

Angehängte Datei  1.png   38,4K   0 Mal heruntergeladen

 

Angehängte Datei  2.png   30,75K   0 Mal heruntergeladen

 

Set DVMT memory size to MAX and "Internal Graphics Memory Size" (could be titled differently in your BIOS) to 64MB.

 
ig-platform-id: 01660000, Stolen RAM for FB: 96MB, Pipes: 3, Ports: 4, FBMem: 3
ig-platform-id: 01660001, Stolen RAM for FB: 96MB, Pipes: 3, Ports: 4, FBMem: 3
ig-platform-id: 01660002, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 1, FBMem: 1
ig-platform-id: 01660003, Stolen RAM for FB: 64MB, Pipes: 2, Ports: 2, FBMem: 2
ig-platform-id: 01660004, Stolen RAM for FB: 32MB, Pipes: 3, Ports: 1, FBMem: 1
ig-platform-id: 01660008, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3
ig-platform-id: 01660009, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3
ig-platform-id: 0166000A, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2
ig-platform-id: 0166000B, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2
ig-platform-id: 01620005, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2
 
Laut der Liste gibt´s mit der 0166000A 3 Ports, was auch mit Deinem ioreg übereinstimmt. Im ioreg liegt das Display auf Port 3.
Laut Liste hat 01660003 nur 2 Ports, was nicht mit Deinem ioreg übereinstimmt. Hier gibt es 4 Ports und das Display liegt auf Port 4. Allerdings ist jetzt der acpi-path vorhanden mit der DSDT-DSM-HD4000-Methode.
 
Vielleicht musst Du ja noch das Bios anpassen. Ob das Audio nun geht werden wir sehen. Kannst ja mal alle versuchen nacheinander.
 
Angehängte Datei  DSDT.aml_ 0x0166000a.zip   11,97K   1 Mal heruntergeladen
Angehängte Datei  DSDT.aml_ 0x01660003.zip   11,99K   1 Mal heruntergeladen
Angehängte Datei  DSDT.aml_ 0x01660004.zip   12K   1 Mal heruntergeladen
Angehängte Datei  DSDT.aml_ 0x01660009.zip   12,02K   1 Mal heruntergeladen
 
Zwecks der Auflösungen, vielleicht liegt´s auch am TV, wo Du es dran hängen kannst.
Bei meinem 42" TV wo der Dell dran hängt mit HD5450 habe ich 1080p, 720p und zwei tiefere Auflösungen.
Vielleicht kann diese App SwitchRes oder wie die heißt auch mehr helfen. Damit soll man ja mehr einstellen können.

  • Rising Hobsing gefällt das

Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 GT710 2GB passiv  42" LG  250GB SSD: 10.14.3 DP4 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  250GB SSD: 10.10.5 / 10.14.3 DP4 (APFS)
Medion P9614: C2D T9600  2,80GHz(2,93GHz)  4GB DDR3  GT330M 512MB 23,6" intern  128GB SSD: 10.13.6 / 10.14.3 DP4 (APFS)
root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: all old versions / 10.13.6 / 10.14.2 (HFS+)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.2 (HFS+)
iPhone6 64GB: iOS 10.3.3  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.1.1


#13 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 1.824 Beiträge
  • OSX:10.12
  • Motherboard: Intel DH67VR BIOS 1.60
  • CPU: CoreI3 3225
  • Grafikkarte: Intel HD4000 onboard
Zeige Hardware

Geschrieben 18 November 2017 - 09:58 Uhr

Danke !

Also, erster Test ergab keine sicht- oder hörbaren Veränderungen.

Die "a" DSDT läuft wie immer komplett, die "3" ist nach wie vor ohne HDMI Ton, die "4" genau das selbe und die "9" resettet den Rechner kurz bevor der Desktop erscheint. 

 

zu den Auflösungen des Monitors in den Systemeinstellungen:

Wenn man bevor man auf "skaliert" klickt vorher die "alt" Taste festhält bekommt man alle Auflösungen des Systems zur Auswahl.

Auch erscheint zusätzlich ein "Monitore erkennen" Button, falls ein externer mal nicht gleich erkannt wird, kann man da nachhelfen.

 

App Switch Res läuft zwar, aber hat das selbe Zerstörungsproblem wie OS X allein auch.

 

 

Im MAc sind doch wohl nur "Mobile" Versionen der Intel Chips oder? Kann das daran liegen das ich plötzlich mehr Ports habe als angegeben?

Weil meiner ist ja ne Desktop Version.

Ich bin auch in der Bucht auf der Suche nach einem 7er Intel Board, damit das HD3000 HD4000 Durcheinander weg fällt. Vielleicht hilft das...


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Hack Mini:
Mainboard: 
Intel DH67VR / BIOS 160, Core I3 3225, 4GB RAM, Intel HD4000 onboard 256MB VRAM, 500GB Hitachi HDD

OS X 10.13.4

Hack Billig :
Mainboard: Gigabyte GA-G31M-S2L BIOS F9, Core2Duo 6400, Gigabyte Radeon 5450, 4GB DDR2 RAM, 500GB HDD WDi 2,5"
OS X 10.10.5


#14 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.266 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 18 November 2017 - 16:47 Uhr

Mmh, ich frag mich wie ich noch helfen könnte. Mir fällt da auch nix mehr ein im Moment.
Betreffs niedriger Auflösungen könnte man vielleicht Duallink ausschalten und Low–Res.Mode konfigurieren, aber ob da der TV mitspielt....
Zwecks HDMI–Audio, hast Du mal das UseHDMIAudio im Clover rausgenommen, um zu sehen ob der HDAU–Eintrag in der DSDT greift.

Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 GT710 2GB passiv  42" LG  250GB SSD: 10.14.3 DP4 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  250GB SSD: 10.10.5 / 10.14.3 DP4 (APFS)
Medion P9614: C2D T9600  2,80GHz(2,93GHz)  4GB DDR3  GT330M 512MB 23,6" intern  128GB SSD: 10.13.6 / 10.14.3 DP4 (APFS)
root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: all old versions / 10.13.6 / 10.14.2 (HFS+)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.2 (HFS+)
iPhone6 64GB: iOS 10.3.3  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.1.1


#15 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 1.824 Beiträge
  • OSX:10.12
  • Motherboard: Intel DH67VR BIOS 1.60
  • CPU: CoreI3 3225
  • Grafikkarte: Intel HD4000 onboard
Zeige Hardware

Geschrieben 18 November 2017 - 19:26 Uhr

Geholfen hast Du doch schon genug. Ich glaube es liegt einfach am System.

So etwas wie Intel 6er Board mit 7er CPU gibt es beim Mac ja nie, deshalb wird da immer ein Konflikt vorliegen.

 

Ich schau mal allein weiter, vielleicht hilft der Zufall ja nochmal..

Es geht ja auch um Nebensächliches, wie alte Games, das System läuft ja tiptop


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Hack Mini:
Mainboard: 
Intel DH67VR / BIOS 160, Core I3 3225, 4GB RAM, Intel HD4000 onboard 256MB VRAM, 500GB Hitachi HDD

OS X 10.13.4

Hack Billig :
Mainboard: Gigabyte GA-G31M-S2L BIOS F9, Core2Duo 6400, Gigabyte Radeon 5450, 4GB DDR2 RAM, 500GB HDD WDi 2,5"
OS X 10.10.5


#16 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.266 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 19 November 2017 - 10:21 Uhr

Ich helfe ja immer gern und ich glaube auch nicht, dass es an der 7er CPU liegt. Ich hab ja auch IntelCPU, die so nie verbaut wurde.

Vielleicht ist der TV mit den Auflösungen überfordert. Hast Du es mal an einem Monitor versucht? Die sind da ja doch spezifischer als ein TV.

 

Hast Du auch mal den Treiber von Clover für /Drivers64UEFI den CsmVideoDxe-64 versucht, kann ja mit CloverConfigurator nachinstalliert werden.

Beschreibung:
64Bit Video-Treiber für Clovers GUI, erlaubt die Auswahl von mehr Auflösungen.
Basierend auf dem CSM-Modul des UEFI-Bios, CSM muss dort aktiviert werden.
Eventuell startet Clover nicht, es kann auch Probleme beim Aufwachen des Systems geben.
Bitte Vorsichtsmaßnahmen treffen.

 

Heute hat al6042 noch ein Hinweis gepostet.

https://www.hackinto...uell-zu-pushen/

Dort gibt´s einen externen Link zur App.

Vielleicht kann man damit was anfangen.


Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 GT710 2GB passiv  42" LG  250GB SSD: 10.14.3 DP4 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  250GB SSD: 10.10.5 / 10.14.3 DP4 (APFS)
Medion P9614: C2D T9600  2,80GHz(2,93GHz)  4GB DDR3  GT330M 512MB 23,6" intern  128GB SSD: 10.13.6 / 10.14.3 DP4 (APFS)
root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: all old versions / 10.13.6 / 10.14.2 (HFS+)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.2 (HFS+)
iPhone6 64GB: iOS 10.3.3  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.1.1


#17 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 1.824 Beiträge
  • OSX:10.12
  • Motherboard: Intel DH67VR BIOS 1.60
  • CPU: CoreI3 3225
  • Grafikkarte: Intel HD4000 onboard
Zeige Hardware

Geschrieben 19 November 2017 - 13:53 Uhr

Ich meine ja auch 7er CPU im 6er Board, wo der HDMI Sound als HD3000 und die Grafik als HD4000 erkannt. wird.

Wobei die Unterschiede für den Ton im Chip selbst bestimmt klein sind. Deshalb wird das überhaupt nur gehen.

 

Den Clover Treiber werde ich mal testen.

 

Ich habe es an einem 24" Samsung Monitor mit HDMI zu DVI Adapter getestet, das selbe wie beim 24 " TV .

 

Ich versuche noch rauszufinden, warum das mit dem Zusatzeintrag im Clover (01660003) läuft.

Und warum da der TV am (nicht existenten) Port 4 der HD4000 hängen soll.

 

Kann das sein, dass der TV, weil er ja nur einmal existiert, bei der Übermittlung der Auflösungsdaten an den Grafikcontroller

diese Daten nur an die Ports 1 oder 2 abgibt, weil die ja physisch vorhanden sind?

Und OS X die Ports 3 und 4 (weil nur in Software vorhanden) mit Standardwerten betreibt mangels Angaben vom (virtuell) angeschlossenen Gerät?

Und da der TV in diesem Fall , wie Du ermittelt hast am Port 4 hängt, dann diese Standardwerte bekommt und sie auch verdaut?

 

In den Systemeinstellungen werden die Auflösungen vom "Monitor 2" nämlich auch richtig 640x480  800x600  1024x768 usw. angeboten!! Wie bei einem Standard Monitor.

Während bei "Monitor 1 " wie immer 1080p 1080i 720p stehen! Eben TV- und nicht Monitorangaben.

Dass  der HDMI Ton nicht an einem normalen Monitor abgeben wird versteht sich ja von selbst. OS X ist dazu schlau genug.

 

Deshalb ja auch Dein Tipp, versuche es mit einem richtigen Monitor. Habe ich schon verstanden.

 

Das würde aber heissen, das wenn ich in meinem Fall diese automatische Erkennung und Übermittlung der Daten vom TV verhindern könnte,

es laufen sollte. Wäre ja der gleiche Fall wie an Port4. Vom Ton mal abgesehen.

 

Ich überlege gerade, mir mal einen Monitor mit HDMI Port und Ton zu borgen. Ich habe da jemanden, der so ein Ding rumstehen hat.

Das würde vielleicht mehr Licht in die Sache bringen.

 

Und wie gesagt, das hier ist ein Freizeitspass, wenn ich nichts anderes zu tun habe. Hektik fehl am Platz...

 

Mit Wine2.0 läuft z.B. Myst 4 wie geölt, wo es mit VM Ware Fusion unspielbar träge ist. (die Krücke mit dem Zusatzeintrag im Clover)

Mich juckt es nochmal die alten Dinger durchzuzocken ohne Windows 98 vorkramen zu müssen.

 

EDIT1:  Es gibt wohl die Möglichkeit einen gefakten Monitor dem System zu verkaufen, das EDID zu überrollen

             mit Clover


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Hack Mini:
Mainboard: 
Intel DH67VR / BIOS 160, Core I3 3225, 4GB RAM, Intel HD4000 onboard 256MB VRAM, 500GB Hitachi HDD

OS X 10.13.4

Hack Billig :
Mainboard: Gigabyte GA-G31M-S2L BIOS F9, Core2Duo 6400, Gigabyte Radeon 5450, 4GB DDR2 RAM, 500GB HDD WDi 2,5"
OS X 10.10.5


#18 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.266 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 19 November 2017 - 15:36 Uhr

Also, EDID könnte ich Dir in die DSDT einbauen. Dafür müsstest Du nur unter Windows aus der Registry die EDID auslesen. Könnte man ja versuchen, aber ob dat was bringt, naja?! Müsste natürlich erst Windows drauf.

 

War es bei VM Ware Fusion und dem ganzen virtuellem Kram nicht so, dass man dort keine echte Grafik hat und es nur geschleift wird, virtuell?

 

Betreffs der Portanzahl würde ich mir jetzt nicht so viel Gedanken machen, denn diese Listen sind schon alt und vielleicht hat Dein Chip tatsächlich diese Ports.

 

Aber mal was anderes, OSX erkennt sehr wohl ob es sich um einen TV, einen Beamer oder um einen Monitor handelt und erkennt die möglichen Auflösungen. Man erkennt es daran, dass auf einem TV oder Beamer kein NightShift in der Systemeinstellung/Monitor auftaucht. Only Monitor.

Hier bei mir so getestet mit TV und Beamer.

Die 0166000a ist wohl für Desktoprechner, welche ja bei Dir auch richtig läuft.

Die 01660003 ist wohl für Laptop´s, die ja ein internes Display haben, oft als eDP angeschlossen. Mich würde hier mal interessieren ob OSX mit der 01660003 somit durcheinander gebracht wurde und er den TV nicht mehr als TV erkennt und Du deshalb diese Auflösungen bekommen hast. Ferner schaue mal ob hier NightShift auftaucht!


Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 GT710 2GB passiv  42" LG  250GB SSD: 10.14.3 DP4 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  250GB SSD: 10.10.5 / 10.14.3 DP4 (APFS)
Medion P9614: C2D T9600  2,80GHz(2,93GHz)  4GB DDR3  GT330M 512MB 23,6" intern  128GB SSD: 10.13.6 / 10.14.3 DP4 (APFS)
root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: all old versions / 10.13.6 / 10.14.2 (HFS+)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.2 (HFS+)
iPhone6 64GB: iOS 10.3.3  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.1.1


#19 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 1.824 Beiträge
  • OSX:10.12
  • Motherboard: Intel DH67VR BIOS 1.60
  • CPU: CoreI3 3225
  • Grafikkarte: Intel HD4000 onboard
Zeige Hardware

Geschrieben 19 November 2017 - 15:42 Uhr

Mach ich, Windows 7 ist ja auf der 2. Platte....

 

Aus der IOReg mit der 0003 geht da nichts draus vor oder?

Kein Nightshift bei Monitor..

Ok, der Haken bei "FakeEDID" im Clover sorgt für den 2 Monitor im System.

Trage ich keine ig Platform ID dazu ein , habe ich auch 2 Monitore UND Ton, aber zerstörte Auflösung.

Trage ich nur die ig Platform ID 0x01660003 ohne FakeEDID ein, habe ich keinen Ton und keine Auflösungen.

Nur die Kombi von beiden funktioniert, obwohl bei Fake EDID ja nur Nullen sind....

In allen Fällen wir mein Gerät mit Namen erkannt. 


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Hack Mini:
Mainboard: 
Intel DH67VR / BIOS 160, Core I3 3225, 4GB RAM, Intel HD4000 onboard 256MB VRAM, 500GB Hitachi HDD

OS X 10.13.4

Hack Billig :
Mainboard: Gigabyte GA-G31M-S2L BIOS F9, Core2Duo 6400, Gigabyte Radeon 5450, 4GB DDR2 RAM, 500GB HDD WDi 2,5"
OS X 10.10.5


#20 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.266 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 19 November 2017 - 16:20 Uhr

ok, aber mit der alten DSDT und 0x01660003 hattest Du doch mehr Auflösungen, oder?

Bei der letzten ist ja der HD4000-iGPU-Eintrag drin.

 

Deine ioreg´s zeigen einige kleine Unterschiede

 

beim ioreg 0x0166000a connector-type <00 08 00 00> 08 ist HDMI, oder?

 

beim ioreg 0x01660003 connector-type <00 04 00 00> 04 ist DVI, oder? Keine Ahnung.

Ferner gibt´s hier einen Wert IOFBHDMIDongleROM <00 00 00 00 00 00 00 00 01 00 00 00 00 00 00 00>, welchen es bei der anderen nicht gibt.


Dell Optiplex 780: C2Q Q9400 2,66GHz 8GB DDR3 GT710 2GB passiv  42" LG  250GB SSD: 10.14.3 DP4 (APFS)
Medion E7216: i3-380M 2,53GHz 8GB DDR3  Intel HD Grafik Ironlake 17" intern  250GB SSD: 10.10.5 / 10.14.3 DP4 (APFS)
Medion P9614: C2D T9600  2,80GHz(2,93GHz)  4GB DDR3  GT330M 512MB 23,6" intern  128GB SSD: 10.13.6 / 10.14.3 DP4 (APFS)
root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  ATI Radeon HD5770 1GB  30" Cinema 2x250GB SSD: all old versions / 10.13.6 / 10.14.2 (HFS+)
Macmini3,1: C2D P7550  2,26GHz  4GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.13.6 / 10.14.2 (HFS+)
iPhone6 64GB: iOS 10.3.3  iPad Pro 9,7" 32 GB Wi-Fi: iOS 12.1.1





Aktive Besucher in diesem Forum: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0