Zum Inhalt wechseln

Foto
- - - - -

Clover DSDT, ich komme nicht weiter


  • Bitte melde dich an um zu Antworten
Eine Antwort in diesem Thema

#1 OFFLINE   granate15

granate15

    ./mehr Member

  • Members
  • PIPPIPPIP
  • 45 Beiträge
  • OSX:10.8
  • Motherboard: ASUS P7P55D
  • CPU: Intel I5 650
  • Grafikkarte: Zotac GeForce GT 710 2048 MB

Geschrieben 12 Dezember 2017 - 16:31 Uhr

Hallöchen,

 

auf meinem Läppi läuft ein 10.12 gebootet mit Clover.
Seit Wochen versuche ich das System dahinzubringen wie ich es haben möchte. Wenn ich von Festplatte boote funktioniert alles außer der Batterieanzeige, die bei einem Laptop nicht unwichtig ist.
Ich habe noch einen Clover auf USB installiert. Beim Boot davon funktioniert die Batterieanzeige aber Backlight nicht und einige andere Kleinigkeiten wie die FN-Tasten. Außerdem bootet ML nicht (ACPI Fehler).
Ich bekomme es nicht auf die Kette die EFI´s so zu kombinieren daß alles funktioniert. Hilfe wäre da sehr willkommen.
Als Anhänge mal die kompletten EFI-Ordner und ein aktueller origin-Ordner.Angehängte Datei  EFI_Stick.zip   9,42MB   3 Mal heruntergeladenAngehängte Datei  EFI_Boot.zip   5,96MB   1 Mal heruntergeladenAngehängte Datei  origin.zip   57,29K   0 Mal heruntergeladen
Es läuft auch noch ein ML auf dem alles funktioniert, gebootet von EFI_Boot.
 
Es gibt viele gutgemeinte Anleitungen im Netz eine DSDT.aml zu patchen. Den Versuch diese nachzuvollziehen habe ich aufgegeben. Dumm, wenn man nicht weiß wie man mit den ganzen Fehlermeldungen umzugehen hat.
 
Leo


#2 ONLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 3.965 Beiträge
  • Locationleft behind the moon
  • OSX:10.14
  • Motherboard: Dell Optiplex 780 MT
  • CPU: C2Q Q9400 2,66GHz
  • Grafikkarte: GT710
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 13 Dezember 2017 - 11:09 Uhr

Ziemliches Chaos.

 

Du solltest erst einmal ein wenig lesen, betreffs Cloverinstallation und deren Treiberauswahl, je nach Bios und betreffs der grundlegenden Einstellungen:

https://www.root86.c...installieren-…/

 

Im drivers64UEFI sind keine zusätzlichen Treiber installiert worden.

 

Im EFI-Stick liegt unter EFI/Clover/ACPI/patched eine gepatchte dsdt.aml, im EFI_Boot nicht, daher vermutlich auch die Unterschiede. In der config.plist ist der Name in Großschrift "DSDT.aml" angegeben. Ob Clover die Schreibweise egal ist kann ich nicht sagen. Die .dsl-Dateien sind dort überflüssig. Damit kann Clover nicht´s anfangen.

 

In allen config.plist´s ist kein SMBIOS gesetzt. Hier sollte es für einen Laptop ein mobiles SMBIOS sein, was Deiner Hardware nahe kommt. Irgendwas wie MacBookProxx.x denke ich.

 

CsrActiveConfig steht auf 0x3E7, keine Ahnung was der Wert soll. Der Wert 0x67 wäre richtig, welcher das SIP abschaltet.

 

Kext Inject steht auf "Detect", hier ist die Einstellung "YES" zu empfehlen.

 

Nun zu den Clover-Kextordnern:

Schwer zu sagen in welchem Ordner nun die Kexte sind, die der Laptop braucht, auf jeden Fall sind die Kexte in /10.12 und /others unterschiedlich.

Dateien wie .efi haben hier nix zu suchen.

Bei den Kext-Ordnern musst Du mal Ordnung schaffen. Sofern Dein ML nicht andere Kexte braucht wie 10.12 kannst Du auch nur den /others nutzen, ansonsten je nach System halt die Ordner /10.8 und /10.12

Erneuere auch mal die Kexte.

FakeSMC ist noch 6.21..., hier sind wir inzwischen auf 6.25...

Auch VoodooPS2Controller.kext für die Tastatur ist schon etwas älter. Könnte man auch mal erneuern. Vielleicht hilft´s ja zwecks der FN-Tasten.

 

Also, erst einmal Aufräumen angesagt, dann wird´s sicher besser.


Medion P9614: C2D T9600  2,80GHz  8GB DDR3  GT330M 512MB 23,6" intern  2x256GB SSD: 10.14.6 / 10.15.6 DP1

THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD intern  512GB SSD + 512GB NGFF M2 SSD: 10.15.6 DP1

root86 AppleHDA patch Thread - / - my blog
Real:
MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  MSI GT710 2GB passiv/ATI Radeon HD5770 1GB  30" Cinema 2x250GB + 480GB SSD: 10.14.6 / 10.15.6 DP1

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB 24"  512/120GB SSD: 10.14.6

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  23" Cinema 500GB SSD: 10.14.6 / 10.15.6 DP1

iPhone6s Plus 32GB: iOS 13.4.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 13.4.1





Aktive Besucher in diesem Forum: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0