Zum Inhalt wechseln

Foto
- - - - -

Intel HD 4400 Mojave NUC D34010WYK


  • Bitte melde dich an um zu Antworten
11 Antworten in diesem Thema

#1 OFFLINE   Elektronenhirn

Elektronenhirn

    ./Elektro

  • Members
  • 331 Beiträge
  • OSX:10.13
  • Motherboard: Asus Z97 Pro
  • CPU: i7 4790k
  • Grafikkarte: Palit GTX 980 Super Jetstream
Zeige Hardware

Geschrieben 06 November 2018 - 20:58 Uhr

Moin,

 

Mojave läuft an sich auf dem NUC, nur die HD4400 will nicht.

An folgendem Link habe ich mich orientiert und alle drei Ids probiert:

https://www.insanely...-whatevergreen/

 

Was mir noch einfällt: Der NUC braucht trotz SSD relativ lange zum booten. Sieht hier jmd. einen Verursacher?

 

Mein EFI hängt bei.

 

Danke schon im Voraus für die Hilfe!


Bearbeitet von AkimoA, 06 November 2018 - 22:16 Uhr.

Power Hack G5: •i7 4790K 4,8Ghz •8gb Ram •Palit GTX 980 Super Jetstream •Asus Z97 Pro •Power Mac G5 Gehäuse •500gb Samsung 850 Evo 

Hack Mini: •i3 4010U 1,7Ghz •Intel HD 4400 •4gb Ram •250gb mSata Kingston SSD  •basiert auf NUC 34010WYK 

Linux Server: •Siemens p5925 •4gb Corsaire Value select •Intel Core2Duo 2,3Ghz •2x320gb HDD •Debian •Nextcloud •Plex

Macbook Pro 2011 15": •i7 2720qm 2,2Ghz •Ati radeon 6750M •4gb Ram •500gb Samsung 850 Evo 

Dell PowerEdge R720: •E5-2643 •32gb ecc ram •2x146gb 15K •4x300gb 10K •ESXI 

 


#2 OFFLINE   AkimoA

AkimoA

  • Administrators
  • 3.851 Beiträge
  • LocationBlack Forest
  • OSX:10.14
  • Motherboard: GA-B360M-DS3H
  • CPU: Intel® Core™ i5-8600
  • Grafikkarte: AMD R9 370x 2048MB GDDR5

Geschrieben 06 November 2018 - 21:29 Uhr

Was genau meinst du wenn du sagst sie will nicht  ? Bildschirm schwarz bei Bootende ? oder keine Beschleunigung 

 

Wie bist du verbunden  ? HDMI  

 

ig platform id in deiner config  hat zuvor in HS funktioniert  ohne zutun ? oder sind das Überreste von deinen Tests?

 

 

OsxAptio Fix Treiber im UEFI64 Ordner sollte immer nur einer sein nicht 2 wie bei dir und auch viele andere Treiber machen darin kein Sinn es sei denn du benutzt FileVault etc .


  • Elektronenhirn gefällt das

#3 OFFLINE   Elektronenhirn

Elektronenhirn

    ./Elektro

  • Members
  • 331 Beiträge
  • OSX:10.13
  • Motherboard: Asus Z97 Pro
  • CPU: i7 4790k
  • Grafikkarte: Palit GTX 980 Super Jetstream
Zeige Hardware

Geschrieben 06 November 2018 - 21:40 Uhr

Habe einfach keine Beschleunigung. Bildschirm ist am DP dran (und dann vga-Adapter).

 

Unter HS und auch unter Mojave hatte ich noch ne fakepcie und intelgraphicsfix Kombination, unter Mojave hängt sich aber der NUC mit dieser Variante bei jedem Video-Playback auf.

Deswegen möchte ich diese Variante einfach mal beiseite lassen.

 

Die id ist die letze ID, die ich getestet habe.

 

UEFI64 gucke ich mal durch.


Power Hack G5: •i7 4790K 4,8Ghz •8gb Ram •Palit GTX 980 Super Jetstream •Asus Z97 Pro •Power Mac G5 Gehäuse •500gb Samsung 850 Evo 

Hack Mini: •i3 4010U 1,7Ghz •Intel HD 4400 •4gb Ram •250gb mSata Kingston SSD  •basiert auf NUC 34010WYK 

Linux Server: •Siemens p5925 •4gb Corsaire Value select •Intel Core2Duo 2,3Ghz •2x320gb HDD •Debian •Nextcloud •Plex

Macbook Pro 2011 15": •i7 2720qm 2,2Ghz •Ati radeon 6750M •4gb Ram •500gb Samsung 850 Evo 

Dell PowerEdge R720: •E5-2643 •32gb ecc ram •2x146gb 15K •4x300gb 10K •ESXI 

 


#4 OFFLINE   AkimoA

AkimoA

  • Administrators
  • 3.851 Beiträge
  • LocationBlack Forest
  • OSX:10.14
  • Motherboard: GA-B360M-DS3H
  • CPU: Intel® Core™ i5-8600
  • Grafikkarte: AMD R9 370x 2048MB GDDR5

Geschrieben 06 November 2018 - 22:08 Uhr

Gib mal folgende Outputs im terminal 

 

gfxutil -f IGPU

 

gfxutil -f  GFX0

 

 

Tool angehangen 

 

 

und bring dein Clover mal auf die aktuellste Version du bist auf 4630 3.August :)   stell sicher das du damit wieder bootest und lade diese  neue EFI nochmal hoch die ich dann editiere. Die andere entferne ich wegen Speicherplatz ;) .

Angehängte Dateien


  • Elektronenhirn gefällt das

#5 OFFLINE   Elektronenhirn

Elektronenhirn

    ./Elektro

  • Members
  • 331 Beiträge
  • OSX:10.13
  • Motherboard: Asus Z97 Pro
  • CPU: i7 4790k
  • Grafikkarte: Palit GTX 980 Super Jetstream
Zeige Hardware

Geschrieben 06 November 2018 - 22:15 Uhr

Elektro-Mini:gfxutil Elektro$ ./gfxutil -f IGPU

DevicePath = PciRoot(0x0)/Pci(0x2,0x0)

Elektro-Mini:gfxutil Elektro$ ./gfxutil -f  GFX0

DevicePath not found!


Power Hack G5: •i7 4790K 4,8Ghz •8gb Ram •Palit GTX 980 Super Jetstream •Asus Z97 Pro •Power Mac G5 Gehäuse •500gb Samsung 850 Evo 

Hack Mini: •i3 4010U 1,7Ghz •Intel HD 4400 •4gb Ram •250gb mSata Kingston SSD  •basiert auf NUC 34010WYK 

Linux Server: •Siemens p5925 •4gb Corsaire Value select •Intel Core2Duo 2,3Ghz •2x320gb HDD •Debian •Nextcloud •Plex

Macbook Pro 2011 15": •i7 2720qm 2,2Ghz •Ati radeon 6750M •4gb Ram •500gb Samsung 850 Evo 

Dell PowerEdge R720: •E5-2643 •32gb ecc ram •2x146gb 15K •4x300gb 10K •ESXI 

 


#6 OFFLINE   AkimoA

AkimoA

  • Administrators
  • 3.851 Beiträge
  • LocationBlack Forest
  • OSX:10.14
  • Motherboard: GA-B360M-DS3H
  • CPU: Intel® Core™ i5-8600
  • Grafikkarte: AMD R9 370x 2048MB GDDR5

Geschrieben 06 November 2018 - 22:35 Uhr

Clover updaten , UEFI Ordner säubern 

 

deine SSDT Testhalber entfernen die macht wenn dann eh nur HDMI Sound 

 

Lilu und WEG in den "others" Ordner 

 

hier mal eine test config mit der (0x0A160000)die darauf basiert was mir die Intel Webseite erzählt da du mir keine exakte Device ID  gegeben hast .

 

basierend auf den infos von Andrey von applelife.ru-> ( aus diesem Material u.a ist der IntelFBPatcher entstanden von headkaze ) 

 

 

Und deine Versuche haben nicht funktioniert weil du sie in die Clover Graphics Section eingetragen hast und nicht da wo sie der WEG  in der config abgreift unter Device-> Properties .

 

 

 

s1rTiXp.png

Angehängte Dateien


  • Elektronenhirn gefällt das

#7 OFFLINE   Elektronenhirn

Elektronenhirn

    ./Elektro

  • Members
  • 331 Beiträge
  • OSX:10.13
  • Motherboard: Asus Z97 Pro
  • CPU: i7 4790k
  • Grafikkarte: Palit GTX 980 Super Jetstream
Zeige Hardware

Geschrieben 07 November 2018 - 16:45 Uhr

Also an sich habe ich jetzt Unterstützung, das Videoplayback von einer Applekeynote von Apple.com geht aber z.B. nicht.

Ich sehe nur den ersten Frame und das wars, auch die eigentliche Videolänge bzw. Zeit lädt nicht.

Auch YouTube verhält sich komisch, lädt nach springen in einem Video nicht mehr. Dafür hat der NUC sich bisher noch nicht aufgehängt.

 

Das gleiche Problem hatte ich auch bei einem Freund bei einer UHD 630 (Coffelake) gehabt.

Als ich dort auf Whatevergreen und FB-Patch gewechselt hatte, ging dann das abspielen von einer Applekeynote und YT funktionierte auch.

Dennoch will bei ihm Netflix in Safari bis heute nicht, in Mozilla geht es aber. Aber das ist ja ne andere Baustelle.

 

Somit ist meiner Meinung nach, das Testen einer Applekeynote immer ne gute Sache, um zu sehen, ob wirklich alles funktioniert. Keine Ahnung, was Apple auf der eigenen Website anders macht.


Power Hack G5: •i7 4790K 4,8Ghz •8gb Ram •Palit GTX 980 Super Jetstream •Asus Z97 Pro •Power Mac G5 Gehäuse •500gb Samsung 850 Evo 

Hack Mini: •i3 4010U 1,7Ghz •Intel HD 4400 •4gb Ram •250gb mSata Kingston SSD  •basiert auf NUC 34010WYK 

Linux Server: •Siemens p5925 •4gb Corsaire Value select •Intel Core2Duo 2,3Ghz •2x320gb HDD •Debian •Nextcloud •Plex

Macbook Pro 2011 15": •i7 2720qm 2,2Ghz •Ati radeon 6750M •4gb Ram •500gb Samsung 850 Evo 

Dell PowerEdge R720: •E5-2643 •32gb ecc ram •2x146gb 15K •4x300gb 10K •ESXI 

 


#8 OFFLINE   AkimoA

AkimoA

  • Administrators
  • 3.851 Beiträge
  • LocationBlack Forest
  • OSX:10.14
  • Motherboard: GA-B360M-DS3H
  • CPU: Intel® Core™ i5-8600
  • Grafikkarte: AMD R9 370x 2048MB GDDR5

Geschrieben 07 November 2018 - 17:01 Uhr

Ich hab in der config auch sonst noch ein paar Änderungen vorgenommen bzgl ACPI Patching und SSDT erstellen .

 

Deswegen läuft er jetzt auch sicher etwas smoother.

 

Dein aktuelles Problem ist DRM Protection   dafür kommt Shiki ins Spiel welcher nun auch Teil von WEG ist der aber auch bootflags braucht um aktiviert zu werden.

 

da würde ich laut Beispiel der Manual :

 

 

// Remove forceOfflineRenderer from AppleGVA Info.plist.

// This is required to allow hardware acceleration on several mac models with discrete GPUs

// when only IGPU is available.

// See /System/Library/PrivateFrameworks/AppleGVA.framework/Resources/Info.plist for more details.

ForceOnlineRenderer        = 1,

 

 

folgende boot flag testen  : shikigva=1

 

 

und zum testen ob es aktiviert  kannst du den VDA DecoderChecker ausführen und den Output mal posten .

 

Ich habe jetzt aber schon in mehreren Foren gelesen das  speziell die DRM Geschichte nicht richtig funzt im Moment  oder nur wenn noch ne 2. Grafikkarte mit im Spiel ist und die interne ganz abgeschalten .

 

Wobei man dann QuickSync verliert und denn HEVC Codec Support aber dafür Streamen kann und iTunes Filme schauen.(kommt ja auf dem nuc eh nicht in Frage nur als Erklärbär)

 

Und wenn YT nicht richtig funzt klingt das aber auch ein bisschen danach als ob deine CPU Clocks nicht Sync sind.

Angehängte Dateien


  • Elektronenhirn gefällt das

#9 OFFLINE   Elektronenhirn

Elektronenhirn

    ./Elektro

  • Members
  • 331 Beiträge
  • OSX:10.13
  • Motherboard: Asus Z97 Pro
  • CPU: i7 4790k
  • Grafikkarte: Palit GTX 980 Super Jetstream
Zeige Hardware

Geschrieben 07 November 2018 - 17:14 Uhr

Erstmal vielen Dank,

 

Hardware acceleration is fully supported

logout

 
kommt aber mit und ohne extra Bootflag.

Power Hack G5: •i7 4790K 4,8Ghz •8gb Ram •Palit GTX 980 Super Jetstream •Asus Z97 Pro •Power Mac G5 Gehäuse •500gb Samsung 850 Evo 

Hack Mini: •i3 4010U 1,7Ghz •Intel HD 4400 •4gb Ram •250gb mSata Kingston SSD  •basiert auf NUC 34010WYK 

Linux Server: •Siemens p5925 •4gb Corsaire Value select •Intel Core2Duo 2,3Ghz •2x320gb HDD •Debian •Nextcloud •Plex

Macbook Pro 2011 15": •i7 2720qm 2,2Ghz •Ati radeon 6750M •4gb Ram •500gb Samsung 850 Evo 

Dell PowerEdge R720: •E5-2643 •32gb ecc ram •2x146gb 15K •4x300gb 10K •ESXI 

 


#10 OFFLINE   AkimoA

AkimoA

  • Administrators
  • 3.851 Beiträge
  • LocationBlack Forest
  • OSX:10.14
  • Motherboard: GA-B360M-DS3H
  • CPU: Intel® Core™ i5-8600
  • Grafikkarte: AMD R9 370x 2048MB GDDR5

Geschrieben 07 November 2018 - 17:19 Uhr

Gerne doch nicht dafür du kannst dich auch mal oben bei den Russisches Kollegen durchkramen da hat einer ne AppleVGA gepatched aber leider von 10.14.0 ob die in der 1 auch geht kann ich dir nicht sagen und ob die bei deinem Problemchen weiter hilft auch nicht ;)

 

Hier noch mal alle möglichen shiki  "Patche" und deren Erklärung more or less :

 

Kannst ja auch mal  shikigva=60 / und shikigva=64 testen  

 

der VDA DecoderCh. checkt in erster Linie generell den Graphic Support nicht direkt die shiki Funktionalität perse.

 

Wenn das Offline Plugin Supported ist zeigt er dir das separat an im Decoder Output.. wühl dich mal durch die Flags und check danach immer den output des Decoders, und deine Filmchen .

Vlt findest du eine passende Kombo für deine Probleme.

 

 


ShikiGVAPatches {

// Remove forceOfflineRenderer from AppleGVA Info.plist.
// This is required to allow hardware acceleration on several mac models with discrete GPUs
// when only IGPU is available.
// See /System/Library/PrivateFrameworks/AppleGVA.framework/Resources/Info.plist for more details.
ForceOnlineRenderer        = 1,
// Remve hweBGRA from AppleGVA Info.plist.
// hweBGRA is not supported by NVIDIA GPUs, so the patch is sometimes required when using NVIDIA
// in a mac model meant to be used with AMD or Intel.
// See /System/Library/PrivateFrameworks/AppleGVA.framework/Resources/Info.plist for more details.
AllowNonBGRA               = 2,
// Prior to 10.13.4 certain GPU+CPU combinations were not meant to provide hardware acceleration and had to be patched.
// The overall problematic configuration list is: NVIDIA+BDW, NVIDIA+SKL, NVIDIA+KBL, AMD+IVB, NVIDIA+SNB.
// Enabled automatically if shikigva is *NOT* passed on 10.13.3 and earlier. All are fixed in 10.13.4.
ForceCompatibleRenderer    = 4,
// Unlike 10.12.6 without security updates and earlier, on 10.13 and latest 10.12.6 AppleGVA patches
// do not apply to all processes, and each process needs to be patched explicitly. This is a bug
// in Lilu, which needs to be explored and fixed. For now this bit ensures that the processes present
// in WHITELIST section of Patches.plist will definitely get the fixes even on 10.13 and 10.12.6.
// On 10.12.6 and 10.13 this must be used if any of the following bits are used:
// - ForceOnlineRenderer
// - AllowNonBGRA
// - ForceCompatibleRenderer
// - ReplaceBoardID
// - FixSandyBridgeClassName
// It is enabled automatically on 10.12 and 10.13 if shikigva is *NOT* passed and ForceCompatibleRenderer or
// FixSandyBridgeClassName are automatically enabled.
AddExecutableWhitelist     = 8,
DisabledUnused16           = 16,
// Replace board-id used by AppleGVA by a different board-id.
// Sometimes it is feasible to use different GPU acceleration settings from the main mac model.
// By default Mac-27ADBB7B4CEE8E61 (iMac14,2) will be used, but you can override this via shiki-id boot-arg.
// See /System/Library/PrivateFrameworks/AppleGVA.framework/Resources/Info.plist for more details.
ReplaceBoardID             = 32,
// Attempt to support fps.1_0 (FairPlay 1.0) in Safari.
// This should technically fix some very old streaming services in Safari, which rely on FairPlay DRM
// similar to the one found in iTunes. Newer streaming services require FairPlay 2.0, which is hardware-only,
// so nothing could be done about them.
// Another way to enable this is to pass -shikifps boot argument.
UnlockFP10Streaming        = 64,
DeprecatedUnused128        = 128

  • Elektronenhirn gefällt das

#11 OFFLINE   Elektronenhirn

Elektronenhirn

    ./Elektro

  • Members
  • 331 Beiträge
  • OSX:10.13
  • Motherboard: Asus Z97 Pro
  • CPU: i7 4790k
  • Grafikkarte: Palit GTX 980 Super Jetstream
Zeige Hardware

Geschrieben 07 November 2018 - 21:33 Uhr

Danke dir :)

Ich melde mich, falls ich noch was herausfinde.

 

Wie gut, dass ich in meinem Hauptsystem ne GTX980 habe, da hat man ganz andere Probleme  :hihihi:


Power Hack G5: •i7 4790K 4,8Ghz •8gb Ram •Palit GTX 980 Super Jetstream •Asus Z97 Pro •Power Mac G5 Gehäuse •500gb Samsung 850 Evo 

Hack Mini: •i3 4010U 1,7Ghz •Intel HD 4400 •4gb Ram •250gb mSata Kingston SSD  •basiert auf NUC 34010WYK 

Linux Server: •Siemens p5925 •4gb Corsaire Value select •Intel Core2Duo 2,3Ghz •2x320gb HDD •Debian •Nextcloud •Plex

Macbook Pro 2011 15": •i7 2720qm 2,2Ghz •Ati radeon 6750M •4gb Ram •500gb Samsung 850 Evo 

Dell PowerEdge R720: •E5-2643 •32gb ecc ram •2x146gb 15K •4x300gb 10K •ESXI 

 


#12 OFFLINE   AkimoA

AkimoA

  • Administrators
  • 3.851 Beiträge
  • LocationBlack Forest
  • OSX:10.14
  • Motherboard: GA-B360M-DS3H
  • CPU: Intel® Core™ i5-8600
  • Grafikkarte: AMD R9 370x 2048MB GDDR5

Geschrieben 08 November 2018 - 07:59 Uhr

Noch ein Auszug aus dem shiki wiki -> https://github.com/a...FAQ.Shiki.en.md

 

 

  • Shiki-based solution for Intel Azul (HD4400, HD4600) without a discrete GPU:

    • IGPU device is enabled, and present with a connector-full AAPL,ig-platform-id prop (e.g. <00 00 16 0a>),  ( haben wir schon )
    • it is reported that renaming IGPU to GFX0 or to an arbitrary name reduces freeze chance;  (kannst du noch testen)
    • GPU driver or framebuffer are patched to disable PAVP/HDCP;  ( noch nix zu gefunden,aber auch nicht gesucht )
    • Hardware video decoder is disabled by a defaults option (video playback will fail after wakeup otherwise); (shikiflag für das offline plugin )
    • IMEI device is present in IOReg;  ( kannst du noch testen , ich hab den Patch Eintrag in deiner config nicht gesehen, und ne  ioreg hatte ich auch nicht von dir  )
    • Mac model set to the one supporting hardware acceleration. ( haben wir schon)

  • Elektronenhirn gefällt das




Aktive Besucher in diesem Forum: 3

Mitglieder: 0, Gäste: 3, unsichtbare Mitglieder: 0