Zum Inhalt wechseln

Foto
* * * * * 1 Stimmen

OpenCore Bootloader


  • Bitte melde dich an um zu Antworten
162 Antworten in diesem Thema

#81 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 19 November 2020 - 17:32 Uhr

Ja, feine Sache. Also sind in Deiner gepatchten  DSDT bereits HPET und die IRQ-Fixes getan, so dass Onboard-Audio wieder mit Inject alcid=15 geht.

 

Zur zweiten Sache, falsche Konfiguration im OC ist natürlich nicht gut. Diesbezüglich lernen wir aktuell ja gerade alle dazu. Ich bin ja auch noch nicht frei von Fehlern, mit meinen sporadischen Boot-Fehlern BigSur auf meinem Thinkpad, aber ich arbeite dran.

Der Fehler bei Dir hat natürlich nix mit AppleALC zu tun.

 

Der letzte Satz ist eigentlich Quatsch. Auf welchen Rechner beziehst Du dies jetzt?

Wenn Onboard-Audio im Bios aus ist, dann kommt unter MacOS auch kein Ton raus, sofern verstehe ich nicht, was Du damit sagen willst.


THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3


#82 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 2.001 Beiträge
  • OSX:10.14
  • Motherboard: ASUS Z97 PRO WIFI AC
  • CPU: CoreI5 4570
  • Grafikkarte: Radeon RX460
Zeige Hardware

Geschrieben 19 November 2020 - 18:03 Uhr

Ich benutze gerade den HP Prodesk 600 G1, der vorher mit Clover und Mojave lief. Für den haben wir die DSDT gemacht.

 

Ist der onboard Audio Chip im BIOS aktiviert und keine DSDT anwesend, gibt es die Kernelpanic wie zitiert. Exakt wie bei dem Testrechner, der sich nicht updaten lies.

 

Ist der onboard Audio CHip im BIOS deaktiviert und keine DSDT anwesend, läuft die Kiste mit HDMI Ton problemlos. Andere Devices gibt es logischerweise nicht.

 

Mit DSDT läuft der HDMI und der analoge Ton.


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Big Hack :
Mainboard: ASUS Z97 Pro WIFI AC / BIOS 3503 Mod 2303, Core I5 4670, 16GB RAM, Radeon RX460, 500GB Maxtor SSD

OS X 11.2.2

Hack Mini :

Mainboard: Gigabyte GA110m-S2H / BIOS F25, Core I5 7500, 8 GB DDR4, Intel UHD630, 240 GB Kingston SSD


#83 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 19 November 2020 - 19:16 Uhr

Mit DSDT läuft der HDMI und der analoge Ton.

 

Dann ist das Ziel doch auch erreicht, oder verstehe ich was falsch?


THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3


#84 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 2.001 Beiträge
  • OSX:10.14
  • Motherboard: ASUS Z97 PRO WIFI AC
  • CPU: CoreI5 4570
  • Grafikkarte: Radeon RX460
Zeige Hardware

Geschrieben 21 November 2020 - 16:38 Uhr

Ja genau, das läuft nun.

Ich wollte nur das Kernel-Panic Problem auflösen. Falls jemand an der selben Stelle hängt. Es konnte ja niemand helfen und das Problem zuordnen.

Dass das durch das Audio zustande kam hätte ich nicht gedacht.

 

Und ich bin beim forschen / lernen, wie ich den Audio Patch in einer SSDT unterbringen kann, denn Du schriebst ja:

 

 

In der heutigen Zeit macht man es mehr und mehr mit zusätzlichen SSDT's und die DSDT bleibt unberührt, somit ist man auch Bios-Update-unabhängig. Ferner noch mit evtl. nötigen Patches unter OC/ACPI/Patch und/oder mittels Device Properties.

 

Ich will ja nicht den Anschluss bei OC verlieren. Und was dazu zu lernen kann nie schaden.


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Big Hack :
Mainboard: ASUS Z97 Pro WIFI AC / BIOS 3503 Mod 2303, Core I5 4670, 16GB RAM, Radeon RX460, 500GB Maxtor SSD

OS X 11.2.2

Hack Mini :

Mainboard: Gigabyte GA110m-S2H / BIOS F25, Core I5 7500, 8 GB DDR4, Intel UHD630, 240 GB Kingston SSD


#85 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 22 November 2020 - 15:09 Uhr

Nicht überbewerten diese Sache, bitte!

Viele User verwenden ihre gepatchte DSDT noch mit OC, welche sie vorher mit Clover in Betrieb hatten.

Sofern alles geht bei diesem Rechner ist doch alles gut, zumal für einen älteren Rechner vermutlich ohnehin kein Bios-Update mehr kommt.

Bei einem neuen Rechner kann man ja dann den Weg gehen über SSDT's bzw. DeviceProperties.

Letztendlich führen bekanntlich viele Wege nach Rom.

 

Ich kann Dir aktuell auch nur ein Beispiel von meinem Lappi geben. Aktuell läuft nur dieser mit OC. Alle anderen laufen auch noch mit Clover und gepatchter DSDT.

 

Also als Beispiel:

Ich arbeite ohne DeviceProperties. Die originale DSDT und SSDT's im ROM sind unberührt.

 

Ich habe im OC eine SSDT-Bat für die Batterieanzeige, eine SSDT-PLUG für die CPU und eine SSDT_T450DIV2, in welcher die Devices konfiguriert sind.

Diese kannst Du Dir ja mal anschauen mit MaciASL:

 

Angehängte Datei  SSDT_T450DIV2.aml.zip   2,32K   1 Mal heruntergeladen

 

Im oberen Block wird External auf die Devices in den originalen Dateien gelinkt und dann erfolgt der Konfigurationsteil genauso, wie man es in der gepatchten DSDT gemacht hätte.

Zusätzlich habe ich dann noch ein paar Einträge unter OC/ACPI/Patch für HPET, die IRQ-Fixes (RTC und TIMR), einige Patches für Tastatur, etc., dat wars auch schon.

 

Letztendlich muss jeder selbst mit OC experimentieren, sofern noch Probleme bestehen.

Oberstes Gebot ist, dass man seine bislang bootfähige OC-EFI auf einen Stick packt auf der dortigen EFI-Partition, so dass man jederzeit wieder über diesen Booten kann und ins System kommt.

Wenn man dat hat, dann kann man an der OC-EFI auf der Platte rumschrauben und testen. Hier und da ein anderer Eintrag, ein anderer Haken oder andere Kext's.

Nie zu viel Änderungen auf einmal machen! Ist aber ein alter Hut, denn dat war bei Clover auch schon so.

 

Es heißt ja immer, man solle die Kext's aktuell halten, jedoch bei älteren Rechnern geht dies nicht immer, z.B. auf meinem Lappi funktionierte lange nur die VoodooPS2Controller.kext Version 1.9.2 von Rehabman.

Damit ging Tastatur voll und Trackpad ohne Gesten. Die neueren Versionen von Github wollten einfach nicht arbeiten.

Nun habe ich nochmals das letze Release der neuen Kext's versucht und siehe da, mein Lappi ist nun voll unterstützt und es gehen alle Gesten mit dem Trackpad auf Catalina und BigSur.

Will damit eigentlich nur sagen, man muss immer wieder am Ball bleiben und viel Testen.

 

Abschließend denke ich, für Deinen älteren Rechner ist die gepatchte DSDT gut so.


  • Konfusius gefällt das

THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3


#86 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 2.001 Beiträge
  • OSX:10.14
  • Motherboard: ASUS Z97 PRO WIFI AC
  • CPU: CoreI5 4570
  • Grafikkarte: Radeon RX460
Zeige Hardware

Geschrieben 22 November 2020 - 18:36 Uhr

Ok Danke, das ist gut erklärt.

Für meinen Kasten gibt es garantiert kein BIOS Update mehr.

 

Ich habe nun alle SSDTs aus dem ACPI Ordner von OC rausgenommen und nur die DSDT allein drin gelassen wie bei Clover.

Dementsprechend auch die config.plist angepasst.

Und das scheint am besten zu gehen, da in der DSDT alles nötige enthalten ist.

Zu viele Köche verderben den Brei. Das wird bei OC nicht anders sein. 

 

Mir geht es ja auch nicht nur um das funktionierende System. Das hatte ich ja schon lange.

Ich will was lernen und das Neue, wie OpenCore verstehen.

Mich ärgert es, dass ich nicht der hilfreichste hier im Forum bin. 

 

Deine Beispiel SSDT werde ich mir ansehen. Mal sehen, was ich davon verstehe.

Dank Deiner langjährigen Hilfe konnte ich ja wenigstens schonmal DSDTs fabrizieren. 


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Big Hack :
Mainboard: ASUS Z97 Pro WIFI AC / BIOS 3503 Mod 2303, Core I5 4670, 16GB RAM, Radeon RX460, 500GB Maxtor SSD

OS X 11.2.2

Hack Mini :

Mainboard: Gigabyte GA110m-S2H / BIOS F25, Core I5 7500, 8 GB DDR4, Intel UHD630, 240 GB Kingston SSD


#87 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 23 November 2020 - 16:39 Uhr

jupp, wenn's vorher auch mit der DSDT allein ging...

...allerdings, wenn Du im Clover den Haken PluginType für die CPU an hattest, dann ist für Dich evtl. noch die SSDT-PLUG.aml interessant, welche ja plugintype=one intus hat.

Dadurch soll ja der neuere X86...Dingsda.kext genommen werden und nicht der alte SMC...Dingsda.

Musst einfach mal schauen, ob die CPU sauber die Multipler wechselt. Nicht dass die CPU nur auf Volldampf geht, dat wäre ja nicht so gut.

 

Wir lernen doch alle aktuell noch, was OC betrifft. Dat muss Dich nicht ärgern.


THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3


#88 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 2.001 Beiträge
  • OSX:10.14
  • Motherboard: ASUS Z97 PRO WIFI AC
  • CPU: CoreI5 4570
  • Grafikkarte: Radeon RX460
Zeige Hardware

Geschrieben 23 November 2020 - 16:51 Uhr

CPU taktet sauber hin und her. Scheint alles stabil zu laufen.

Meine SSD kam auch gerade, aber CCC machte keine bootfähige Kopie. Ich musste neu installieren.

 

 

 

 

 

Angehängte Dateien


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Big Hack :
Mainboard: ASUS Z97 Pro WIFI AC / BIOS 3503 Mod 2303, Core I5 4670, 16GB RAM, Radeon RX460, 500GB Maxtor SSD

OS X 11.2.2

Hack Mini :

Mainboard: Gigabyte GA110m-S2H / BIOS F25, Core I5 7500, 8 GB DDR4, Intel UHD630, 240 GB Kingston SSD


#89 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 23 November 2020 - 17:43 Uhr

Ich kenne mich mit dem IntelPowerGadget auch nicht wirklich aus, aber hatte Dein Rechner bei der Messung im Hintergrund noch viel zu tun?

 

Ich Frage nur, weil der Core AVG bei Dir ziemlich hoch zappelt und den Core Min eigentlich nie auch nur im Ansatz erreicht.

 

Ich habe mein Lappi auch gerade mal gemessen, nur so zum Vergleich:

 

Angehängte Datei  power.png   67,68K   1 Mal heruntergeladen

 


THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3


#90 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 08 Dezember 2020 - 19:54 Uhr

ich habe heute auf das neue Release OC 0.6.4 und alle neuen Kext's gewechselt, läuft bisher, wie vorher auch.


THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3


#91 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 2.001 Beiträge
  • OSX:10.14
  • Motherboard: ASUS Z97 PRO WIFI AC
  • CPU: CoreI5 4570
  • Grafikkarte: Radeon RX460
Zeige Hardware

Geschrieben 09 Dezember 2020 - 17:37 Uhr

Ich habe das Intel Power Gagdet mal unter Windows laufen gehabt.

Da geht die Frequenz bis 0,8 GHz runter. Unter OS X nur bis minimal 1,68 GHz.

 

Du hast recht, da stimmt noch was nicht mit dem Management. 


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Big Hack :
Mainboard: ASUS Z97 Pro WIFI AC / BIOS 3503 Mod 2303, Core I5 4670, 16GB RAM, Radeon RX460, 500GB Maxtor SSD

OS X 11.2.2

Hack Mini :

Mainboard: Gigabyte GA110m-S2H / BIOS F25, Core I5 7500, 8 GB DDR4, Intel UHD630, 240 GB Kingston SSD


#92 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 09 Dezember 2020 - 17:42 Uhr

Du solltest Dir mal mittels Script SSDT-Time von GitHub eine SSDT-PLUG.aml erstellen für die CPU unter OC!!!


  • Konfusius gefällt das

THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3


#93 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 2.001 Beiträge
  • OSX:10.14
  • Motherboard: ASUS Z97 PRO WIFI AC
  • CPU: CoreI5 4570
  • Grafikkarte: Radeon RX460
Zeige Hardware

Geschrieben 16 Dezember 2020 - 19:18 Uhr

So ich habe meinen Schrott-Hacki wiederbelebt. Gigabyte  GA-H81M-D2V / I5 4570 / 8GB RAM. Da war das BIOS wieder weg. :sholva:

Ich habe den BIOS2 Chip und den BIOS1 Chip gegeneinander getauscht. Der 2. wurde ja kaum benutzt.

Der läuft nun wieder zuverlässig. Auch mit der RC460.

In dem HP Prodesk 600 G1 kann  man eine längere Grafikkarte zwar stecken, die verdeckt dann aber den Front USB3 Anschluss, was dazu führt,

das der Kasten bei Boot immer eine Warnmeldung ausgibt und man mit F1 den weiteren Bootvorgang bestätigen muss.

Lässt sich auch nicht im BIOS abstellen. Selbst wenn USB3 deaktiviert ist...

Auch sind bis auf einen Anschluss alle SATA Ports durch die Grafikkarte verdeckt. :wiejetzt:

 

Gut. in dem Schrotti ist das kein Problem mehr.

 

Nun das Power Management Problem: Die CPU ist die selbe wie im Prodesk: I5 4570 Haswell.

Ich habe dann unter Windows mit dem SSDT-Time Script eine SSDT-PLUG erstellt. 

Die läuft auch brav mit OC0.6.4 und BS, aber bis 0,8 GHz geht der trotzdem nicht runter. Minimum ist jetzt 1,48GHz.

Ist nach wie vor unruhig im Intel Power Gadget.    :null:

 

Na mal sehen, was ich noch so finde zu dem Thema.


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Big Hack :
Mainboard: ASUS Z97 Pro WIFI AC / BIOS 3503 Mod 2303, Core I5 4670, 16GB RAM, Radeon RX460, 500GB Maxtor SSD

OS X 11.2.2

Hack Mini :

Mainboard: Gigabyte GA110m-S2H / BIOS F25, Core I5 7500, 8 GB DDR4, Intel UHD630, 240 GB Kingston SSD


#94 OFFLINE   AkimoA

AkimoA

  • Administrators
  • 4.095 Beiträge
  • LocationBlack Forest
  • OSX:10.14
  • Motherboard: GA-B360M-DS3H
  • CPU: Intel® Core™ i5-8600
  • Grafikkarte: AMD RX 580 8192MB GDDR5

Geschrieben 17 Dezember 2020 - 06:33 Uhr

https://github.com/s...e-key-cpufriend

 

kannst du ausprobieren der erstellt dir ein CPUFriendDataProvider.kext die du dann mit CPUFriend.kext zusammen benutzen kannst auf dem weg dahin kannst du im script die 800mhz Taktung einstellen .

 

Die Githubrepo scheint noch aktuell zu sein also ein Versuch wert  , und immer ein OC Bootstick mit EFI Backup parat  haben schadet sowieso generell  nie . 


  • Konfusius und MacPeet gefällt das

#95 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 17 Dezember 2020 - 16:20 Uhr

Ich denke, der Hinweis von Aki ist auch ein guter Ansatz. Ich habe damit damit auch noch keine Erfahrungen gemacht, bisher nicht gebraucht, allerdings sind viele User mit CPUFriend's best zufrieden.

 

Die Sache mit dem SSDT-Time Script ist ohnehin so eine Sache. Das Script will ja erst einmal eine DSDT.aml angegeben haben, anhand dessen das Script was erstellen möchte.

Aber welche DSDT sollte man denn nehmen? Die Clean oder die aus dem System mit MaciASL ausgelesene mit allen bereits gemachten Patches intus? Hierbei ändern sich ja auch die Ergebnisse vom SSDT-Time Script.

Ich habe beides getestet und nur mal als Beispiel von meinem Lappi.

Der erstellte HPET-Patch ist hier nicht nutzbar, der bricht sofort das Audio. Hier verwende ich noch den Patch, den ich schon vor OC im Clover hatte und dieser geht.

Die IRQ-Fixes passen.

Die erstellte SSDT-PLUG arbeitet hier auch super.

Will damit auch nur sagen, dass dieses Script auch nicht unfehlbar ist und man sollte jedes Ergebnis immer noch gegenprüfen und nicht blind einsetzen.


THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3


#96 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 11 Januar 2021 - 17:27 Uhr

Nachdem ich mir beim Wechsel von OC0.6.4 auf OC0.6.5 erst selbst ein Ei gelegt habe und es aber inzwischen wieder lief, bin gleich auf OC0.6.6 gegangen, was ja nun Hintergrundbild kann.

Dazu habe ich mir mal ein erstes Testbild gebastelt, muss mir aber noch in Ruhe ein schönes Hintergrundbild basteln.

 

Angehängte Datei  oc_back.png   1,91MB   0 Mal heruntergeladen

 

Ich glaube ein dunkleres Bild kommt besser rüber.

Falls Ihr schöne Hintergrundbilder habt, am Besten mit unserem Logo, dann bitte her damit!

 

Edit:

Hier ist die Schrift schon besser zu sehen:

 

Angehängte Datei  oc_back2.png   2,66MB   0 Mal heruntergeladen

 

Edit2:

Eigentlich ist mir sowas schlichtes lieber...

 

Angehängte Datei  oc_back3.png   930,01K   0 Mal heruntergeladen

 

allerdings bin ich zu doof, mittels Affinity Photo den Text genauso zu versenken, wie es der Apfel unten ist. Verstehe das Programm einfach nicht, mit den vielen Optionen und Schaltern, Filtern und Effekten, Pipette, etc., pp.

Da kann ich noch so viele Filter versuchen. Leider bin ich auch nicht der Grafikexperte, wobei damals mit dem guten alten Micrografx Picture Publisher unter Windows ging sowas alles, selbst für mich als Grafik-NichtsNutz. Gibt's ja leider nicht mehr, wurde ja von anderem Unternehmen geschluckt.

Hab ich zwar noch auf einem Win, aber ich will ja eigentlich keinen Schritt zurück machen.

 

Ich bin gespannt auf Eure Erfahrungen damit.


  • Konfusius gefällt das

THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3


#97 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 2.001 Beiträge
  • OSX:10.14
  • Motherboard: ASUS Z97 PRO WIFI AC
  • CPU: CoreI5 4570
  • Grafikkarte: Radeon RX460
Zeige Hardware

Geschrieben 15 Januar 2021 - 12:00 Uhr

Ich habe heute auch auf OC 0.6.6 geupdated und auch alle Kexts mit. Läuft wie gehabt prima. :yes:

Nur mein grafischer Bootscreen ist weg.  :sholva:

Mit dem Hintergrundbild sind da wohl noch andere Änderungen gemacht worden... 

 

EDIT: "Recources" Ordner aktualisiert > alles wieder da.

          Nun das Hintergrundbild testen...


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Big Hack :
Mainboard: ASUS Z97 Pro WIFI AC / BIOS 3503 Mod 2303, Core I5 4670, 16GB RAM, Radeon RX460, 500GB Maxtor SSD

OS X 11.2.2

Hack Mini :

Mainboard: Gigabyte GA110m-S2H / BIOS F25, Core I5 7500, 8 GB DDR4, Intel UHD630, 240 GB Kingston SSD


#98 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 15 Januar 2021 - 16:22 Uhr

Ok, dat mit dem fehlenden Ordner hast Du selbst gemerkt.

 

Einstellung PickerVariant ist dabei neu. Einstellung zum Beispiel Auto oder Modern

 

Angehängte Datei  PickerVariant.png   45,97K   0 Mal heruntergeladen

 

ferner diese Icons entpackt in den Ordner Recoucses/Image/ legen:

 

Angehängte Datei  Background.icns.zip   5,04MB   4 Mal heruntergeladen

 

Angehängte Datei  ModernBackground.icns.zip   1,86MB   4 Mal heruntergeladen

 

Background wird wohl bei Auto geladen, bei Modern dann das ModernBackground, so wie bei mir

 

Meine Beispiel-Hintergründe sind für FullHD. Die Auflösung sollte zur Auflösung im Picker passen.

 

Wenn Dein Monitor höhere Auflösung kann, bzw. Du Dir selbst ein Bild basteln willst, dann...

 

Kopiere Dir mal aus OpenCore-0.6.6-RELEASE/Utilities/ den Ordner icnspack auf den Desktop.

 

In diesen Ordner kopierst Du auch Dein Hintergrundbild.png in der bereits richtigen Auflösung.

 

Nun Terminal starten (Beispiel):

 

cd ~/Desktop/icnspack

/Users/peet/Desktop/icnspack/icnspack ModernBackground.icns ModernBackground.png ModernBackground.png
 
Zur Erklärung:
Mit dem vorhergehenden cd Befehl wechselt er in den Ordner und die fertige Datei landet auch definitiv dort und Du musst nicht suchen, wo sie gelandet ist.
Das Tool icnspack arbeitet im Terminal leider nicht mit einfacher Eingabe. Du musst das Tool also dort reinziehen.
Sofern Du mit cd im Ordner bist, braucht der Rest keine Pfadangaben. Du kannst die Bilder aber auch reinziehen.
 
Die richtige Syntax ist "icnspack Name.icns Bild1.png Bild2.png".
Das Tool macht normal ja zwei Auflösungen für normale Icons, in 128 und 255, oder so.
In meinem Fall habe ich zwei Mal dat gleiche Bild angegeben in FullHD, da die Auflösung im Picker ohnehin feststeht.
 
Lange Rede, kurzer Sinn, einfach selbst versuchen und dann siehst Du es genau.
Ich bin schon auf Deine Bilder gespannt.

  • Konfusius gefällt das

THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3


#99 OFFLINE   Konfusius

Konfusius

    Tech.Sergeant86

  • Moderators
  • 2.001 Beiträge
  • OSX:10.14
  • Motherboard: ASUS Z97 PRO WIFI AC
  • CPU: CoreI5 4570
  • Grafikkarte: Radeon RX460
Zeige Hardware

Geschrieben 27 Januar 2021 - 19:08 Uhr

So ich bin jetzt mit dem neuen Mainboard unterwegs. Dat is nen ASUS Z97PRO WIFI AC.

Alle läuft bislang sehr gut mit OC 0.6.5.

WIFI und Bluetooth sind noch deaktiviert im BIOS. Da muss ich noch rausfinden ob das unter BS laufen würde. Brauche ich auch nicht unbedingt...

 

Das NVRAM macht mir noch Sorgen. Bei meinem Board geht das wohl so nicht direkt.

Hier kämpft man auch damit:

https://www.hackinto...-z97-pro-gamer/

Wobei in der Anleitung steht:

 

 

Something else to note is that macOS is only able to read nvram.plist but it won't be able to write to nvram.plist unless running the shutdown process. This means running the test above won't work

 

 

Ich will, bevor ich das BIOS modifizieren muss, erstmal die NRAM Emulation testen. Vielleicht reicht das ja.

Ich habe alles wie hier beschrieben gemacht:

https://github.com/d...r/misc/nvram.md

 

Muss da jetzt im EFI nicht eine Datei namens nvram.plist versteckt sein?  Verborgene Dateien anzeigen hab ich schon.

Ich finde das Ding nicht? 


Man sollte sich nicht wundern, dass die Katze genau da Löcher im Fell hat wo die Augen sind !
(Prof. Harald Lesch)

Big Hack :
Mainboard: ASUS Z97 Pro WIFI AC / BIOS 3503 Mod 2303, Core I5 4670, 16GB RAM, Radeon RX460, 500GB Maxtor SSD

OS X 11.2.2

Hack Mini :

Mainboard: Gigabyte GA110m-S2H / BIOS F25, Core I5 7500, 8 GB DDR4, Intel UHD630, 240 GB Kingston SSD


#100 OFFLINE   MacPeet

MacPeet

    ./root86.♡♥♥♥♡

  • Moderators
  • 4.359 Beiträge
  • Locationleft behind the moon
  • OSX:10.6
  • Motherboard: realMac's/Hackintosh's
  • CPU: CPU's vorhanden
  • Grafikkarte: Metal und nonMetal
Zeige Hardware
8 Hardware Favorit(en)

Geschrieben 31 Januar 2021 - 09:27 Uhr

Mit OpenCore kann ich es nicht testen, da mein Lenovo natives NVRAM hat.

 

Bei meinen alten Legacy-Rechnern mit Clover und Einsatz der EmuVariableUefi.efi wird die nvram.plist im Hauptverzeichnis der EFI-Partition sichtbar abgelegt.

 

Angehängte Datei  1.png   31,82K   0 Mal heruntergeladen

 

Ich denke bei OC sollte es auch dort landen, denn im Anleitungs-PDF von OC steht:

 

LegacyEnable

Type: plist boolean
Failsafe: false
Description: Enables loading of NVRAM variable file named nvram.plist from EFI volume root. ...dort steht dazu natürlich noch mehr...

 

Insgesamt sind dort aber scheinbar viele Dinge einzustellen. Nicht ganz leicht, die ganze Sache zu verstehen.

 

Evtl. ist es vielleicht nötig (SIP) csr-active-config auszuschalten, bzw. das nötige Bit mitzugeben, so dass er überhaupt auf die EFI schreiben darf.

 

Ferner schreibt der User aus Deinem Link, dass der NVRAM Zugriff in neueren Bios Versionen abgeschaltet wurde. Wie alt müsste der Rückschritt denn sein, für native Unterstützung?

Es wäre ja nicht der erste Rechner, bei dem neuere Bios Versionen für den Hackintoshbereich eher ungeeignet waren.

 

Ich hoffe, Du bekommst es irgendwie hin.


THINKPAD T450s: i7-5600U  2,60 -3,2 GHz  12GB DDR3  IntelHD 5500  14" FHD  512GB SSD + 512GB NGFF M2 SSD: 11.6.2 / 12.2 RC (OC0.7.5)

RealMacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Cinema/23" Cinema  256GB+512GB SSD  12.2 RC

MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  2x250GB + 480GB SSD + 1TB HDD: 10.15.7 /12.2 RC (OCLP0.3.2)

iMac8,1 24 Zoll: C2D E8435  3,06GHz  4GB DDR2   Nvidia GF 8800 GS 512MB  512/120GB SSD: 10.15.7

Macmini3,1: C2D P7550  2,26GHz  8GB DDR3  GF 9400M 256MB  256GB SSD: 10.15.7

iPhone8 64GB: iOS 15.2.1  iPad Pro 9,7" 32 GB Wi-Fi: iPadOS 15.3





Aktive Besucher in diesem Forum: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0