Zum Inhalt wechseln

Foto
- - - - -

Dell Inspiron 17R 7720 SE Festplatte und SSD sehr langsam


  • Bitte melde dich an um zu Antworten
3 Antworten in diesem Thema

#1 OFFLINE   naquaada

naquaada

    ./Member

  • Members
  • PIPPIP
  • 29 Beiträge
  • Motherboard: GA-Z77N-WiFi
  • CPU: Intel Core i7 3770S
  • Grafikkarte: Intel HD4000

Geschrieben 10 Juli 2019 - 22:17 Uhr

Hallo,

 

ich habe jetzt seit einiger Zeit den oben erwähnten Dell inspiron 17R Special Edition 7720, einen für OSx86 sehr gut geeigneten Laptop. Hier erst mal die Daten:

 

- 17" Non-Glossy Full-HD Display

- Core i7 3730QM 2.39 GHz 6 MB L2-Cache

- bis zu 16 GB 1600 MHz DDR3-RAM

- HM77 Chipset

- nVidia GeForce GT 650 M

- Intel HD 4000 Graphics

- IDT 92HD91Bxx Audio

- Skullcandy 2.1 System mit Subwoofer

- 4x USB 3.0

- 1 MP Webcam

- Realtek Cardreader

- Realtek RTL8105E LAN

- Halfsize Mini PCIe-Slot

- DVD oder Bluray

- Backlit Keyboard

- leise, der Lüfter geht selten an

- integrierte umfangreiche Diagnose-Software

- Warnungen (z.B. bei Ersatzakku) lassen sich abschalten

- Kein Leichtgewicht: Über 3 Kilo

 

 

Folgendes funktioniert:

 

- Intel Grafik mit Backlight Control

- Sound

- WLAN

- LAN

- USB 3.0

- Sleep

 

Die Intel Grafik kann man gut mit Clover, Lilo und WhateverGreen zum Laufen bekommen. Backlight und Color-Profile gehen, habe über DisplayMergeNub.kext eins auf Basis des Macbook Air erstellt. HDMI und VGA funktionieren nicht. Der DCPIManager zeigt FB ID 0x01660004 (Mobile, 1 Ausgang), System Profiler ID 0x01660009 (Mobile, 3 Ausgänge). Mit nVidia Optimus gibt es noch keine Fortschritte? Wenn ich ohne gepatchte dsdt.aml boote, bekomme ich zwar kein Bild auf dem Display, aber HDMI funktioniert und der DCPIManager zeigt dann auch korrekt die FB ID 0x01660009 an. Das HDMI funktioniert, ist ganz wichtig für mein Wacom Cintiq Hybrid Grafiktablett.

 

Mt AppleALC und ähnlichen Sachen habe ich nichts hinbekommen, aber der gute alte VoodooHDA kann es. Lautstärkereglung per Tastatur gehen über den Fix auch. Es wird zwar kein Kopfhörerausgang angezeigt, aber wenn man einen einsteckt, ändert sich die Bezeichnung. Die Regler für Lautsprecher/Kopfhörer können auch unterschiedliche Werte haben. Das integrierte Mikro hat eine angemessene Lautstärke. Leider wird der Subwoofer nicht erkannt.

 

Die originale Intel WLAN/BT-Karte funktioniert natürlich nicht, ich habe eine Atheros AR9285 drin. Realtek RTL8105E LAN funktioniert mit RealtekR1000SL.kext, habe ich aber nicht getestet. Es soll nur ein 10/100 Mbit-Controller sein, obwohl in den Systemeinstellungen 1000baseT angezeigt werden. Es gibt keine Auswahl für den Duplexmodus.

 

USB 3.0 funktioniert in voller Geschwindigkeit. Es ist ein Intel-Chipsatz.

 

Sleep funktoniert ebenfalls vollständig: Deckel zu - Rechner aus. Deckel auf - Rechner läuft, keine Probleme mit Sound oder WLAN. Das ist ausgesprochen wichtig bei einem Laptop.

 

 

Nicht funktioniert:

 

- nVidia GT 650M Graphics

- HDMI/VGA

- Cardreader

- Trackpad

- Batteriemangement nicht vollständig

- Ruckler

- Festplatte/SSD

 

Optimus wird nie unter OSx86 laufen? Wie sieht es unter Linux aus?

 

Der Cardreader wie üblich auch ein Problem, obwohl er USB ist. Einträge in Sintetek-rt-sx.kext und AppleStorageDevices haben nichts gebracht.

 

Das Trackpad ist so lala: Ich hatte mal einen VoodooPS2Controller, der in den Systemeinstellungen das Trackpad gelistet hatte. Allerdings gab es da immer Schwierigkeiten, z.B. ließ sich ein Fenster nicht verschieben, wenn man die Trackpadtaste festhielt und dann versuchte, sie über das Trackpad zu verschieben. Vielleicht hat sich der Trackpadtreiber aber auch mit dem PS/2-Maustreiber gebissen, der ja gleichzeitig geladen wurde. Ich muß diese Version von VoodooPS2Controller.kext unbedingt nochmal finden. Am Laptop kann man mit fn + F3 das Trackpad abschalten, dann geht darüber eine LED an. Das funktonierte bei dieser Version auch.

 

Die Batterielaufzeit wird nicht korrekt berechnet, es gibt auch keine Warnmeldung, wenn der Akku leer ist. Der Rechner geht dann einfach aus. Ich habe jetzt einen 7800 mAh-Akku drin. Das BIOS hat wegen des Akkus eine Warnmeldung ausgegeben, aber die kann man abschalten.

 

Gelegentlich bleibt das System kurz hängen, vielleicht für eine Sekunde. Das merkt man nur, wenn man ein Video abspielt oder Musik hört. Öffnet man dann z.B. das Fenster vom Hardwaremonitor, werden diese Ruckler wesentlich häufiger. Ich kenne dieses Problem aus frühesten OSx86-Zeiten, als die ersten Dual-Core-CPUs rauskamen. Ich hatte es aber auf keinem System, auch auch meinem AMD Opteron 185 nicht. Selbst mein Doppelprozessorsystem (2x Xeon L5410 Sockel 771, Supermicro Serverboard) ruckelt nicht.

 

Ganz schlimm ist allerdings die Festplatte. Bei einer WD 1TB mit 5400 rpm bekomme ich in Xbench beim Sequentiellen Lesen nicht mehr als 38 MB/s. Zufälliges Lesen sogar nur 0.53 MB/s ! Alle anderen Werte sind normal. Mag das bei einer Festplatte schon schlimm sein, wird es bei der mSATA-SSD noch ärger: Sequentiell höchstens 50 MB/s, zufällig 26 MB/s ! Der mSATA-Port ist zwar nur mit SATA2 angebunden, die Festplatte aber mit SATA3. Wie können so niedrige Werte zustandekommen? Ich habe diverse Chipsets, nForce4, H61, Z77, GeForce MCP79, Intel 5400 (Serverboard), alle haben höhere Lesegeschwindigkeiten.

 

OS X soll dann später auf eine SSD installiert werden, die in einem Fesplattenslot steckt. Einer der beiden liegt direkt an der Heatpipe der CPU und wird so für Festplatten zu warm. Von der mSATA-SSD kann man übrigens nicht vom BIOS aus booten. Man muß also auf der Festplatte einen Bootloader installieren und so von der SSD booten.

 

 

Konfiguration:

 

Ich verwende eine gepatchte dstdt.aml, die die nVidia deaktiviert. Aktuell nutze ich 10.9.5 auf MBR, kommt später auf die SSD mit GPT. Der TRIM Patch ist in Clover aktiviert. Andere OS X-Versionen muß ich mal antesten, waren in meinen Desktopsystemen mit HD6870 Grafik so langsam, daß es sich nicht gelohnt hat. Ich habe diverse Kexte gepatcht, die unter Mavericks eigentlich nicht mehr funktionierten. Dazu mußten einfach nur einige Abhängigkeiten geändert verden, z.B.

<key>com.apple.kpi.iokit</key>
<string>14.0.0</string>

in
<key>com.apple.kpi.iokit</key>
<string>8.0.0</string>

 

 

Es werden alle für neuere Systeme gedachte Kexte unter Mavericks geladen, Lilo, WhateverGreen, und WhateverPatchedKext.too

 

Im BIOS ist Virtualisierung deaktiviert, SATA steht auf AHCI. Viel mehr geht ja auch nicht einzustellen. Es gibt für den Dell 7720 zwar ein BIOS, bei dem alle Funktionen freigeschaltet sind, aber das läuft nur auf den Geräten mit einem Core i7 3710QM-Prozessor.

 

Also das Problem mit der Festplatte bzw. SSD stellt mich echt vor ein Rätsel. Allerdings ist mein Gigabyte GAZ77-DS3H beim Lesen von Festplatte nicht schneller, selbst bei einer WD Black. Da ist es mir allerdings noch nie aufgefallen. Ich finde zu dem Thema auch nichts. Es wäre echt klasse, wenn ihr da ein paar Tips habt, denn der Dell 17R SE 7720 ist ein wirklich schöner Laptop. Und viele Probleme gibt es ja nicht mehr.

 

Im Anhang noch der EFI-Folder, der auf einer eignenen 128 MB-Partition im HFS+ Format liegt. Kexte sind bei mir alle in System/Library/Extensions, ich habe nur die für den Dell gepatchte bzw. notwendige dazugepackt. Zusätzlich sind noch DisplayMergeNub.kext dabei und drei Colorprofile. Eins ist vom Macbook Air und eins ist für den Dell, wenn man normal von vorne schaut. Es ist noch ein dunkleres dabei, wenn man von oben schaut, also wenn man den Laptop auf den Knien hat.

 

Beste Grüße, E29.

Angehängte Dateien


Bearbeitet von naquaada, 13 Juli 2019 - 13:29 Uhr.


#2 OFFLINE   naquaada

naquaada

    ./Member

  • Members
  • PIPPIP
  • 29 Beiträge
  • Motherboard: GA-Z77N-WiFi
  • CPU: Intel Core i7 3770S
  • Grafikkarte: Intel HD4000

Geschrieben 13 Juli 2019 - 13:32 Uhr

So, ich habe jetzt auch zur mSATA-SSD eine SATA-SSD drin und mein Mavericks darauf geklont. Weder das Booten noch das Kopieren von Dateien ist schneller als auf einer Festplatte. Das ist natürlich Mega-frustrierend. Kann mir vielleicht jemand helfen, eine korrekte dsdt.aml für meinen Laptop zu erstellen?



#3 ONLINE   SparkX

SparkX

    Moderator

  • Moderators
  • 1.396 Beiträge
  • OSX:10.14
  • Motherboard: iMac (2017)
  • CPU: i7-7700K 4.2 GHz
  • Grafikkarte: Radeon Pro 580 8192 MB
Zeige Hardware
1 Hardware Favorit(en)

Geschrieben 13 Juli 2019 - 13:56 Uhr

Sicher, unser Spezialist MacPeet macht aber mal ein paar Tage frei, Geduld ist angesagt.

 

Ich kann Dir bei Deinem Problem leider nicht helfen....


iMac (2017)

macOS 10.15 DP3,

i7-7700K, 4x 8GB CL17/2400 S0-DIMM,
3,12 TB Fusiondrive,
Apple Superdrive,

Radeon Pro 580 8192 MB.

 

MacMini (2014)
macOS 10.15 DP3, 

2,6Ghz i5, 8GB, 126GB SSD,

Apple Superdrive,
Grafik integriert Intel Iris.

 

iPhone XS iOS 13 DP3,  iPad 3 WiFi&Cellular iOS 9.3.5, iPad 5. Gen. Wifi&Cellular iOS 13 DP3,

iPad mini IOS 9.3.5 & mini 2 iOS 12.4 DP6,

2x Apple TV 4K tvOS 13 DP3, 3x Apple HomePod iOS 12.3, iPod 6.Gen. iOS 12.4 DP6,

AppleWatch Alu Series 3 watchOS 6 DP3,  AirPods 6.3.2, iPod 4Gen. iOS 6.1.6.


#4 OFFLINE   naquaada

naquaada

    ./Member

  • Members
  • PIPPIP
  • 29 Beiträge
  • Motherboard: GA-Z77N-WiFi
  • CPU: Intel Core i7 3770S
  • Grafikkarte: Intel HD4000

Geschrieben 13 Juli 2019 - 20:19 Uhr

Jo, ist klar. Das Schreiben ist übrigens schnell. Wenn ich eine Datei erst in eine RAM-Disk kopiere (Mit der PrefPane Esperance DV geht das) und dann auf die SSD kopiere, geht es schön fix.

 

Die schon mal verschwundene Fehlermeldung

 

ACPIBatteryManager: WARNING! fMaxCapacity > fDesignCapacity. adjusted fMaxCapacity from 7919, to 7800

 

ist wieder autgetreten. Der erscheint aber nicht nur einmal, sondern läuft auch im Betrieb dauernd durch. In der ​Konsole wird diese Fehlermeldung dauernd neu ausgegeben.​


Bearbeitet von naquaada, 13 Juli 2019 - 20:24 Uhr.





Aktive Besucher in diesem Forum: 5

Mitglieder: 0, Gäste: 5, unsichtbare Mitglieder: 0